Skip to:
Content
Pages
Categories
Search
Top
Bottom

Topic not displayed for user but is for admin

Viewing 7 replies - 1 through 7 (of 7 total)

  • ecoportaluk
    Participant

    @ecoportaluk

    This is fixed now


    Robin W
    Moderator

    @robin-w

    Greta, glad you’re ok now !


    nerak_d
    Participant

    @nerak_d

    I am having this exact same issue, and cannot resolve it. Dave, how did you fix it? I have tried deactivating all plugins tangentially related to bbpress and even switching themes. There are a number of related threads about this issue on the forum but none have any real solutions provided.

    Any and all guidance would be greatly appreciated!!
    Thanks,
    Karen


    Robin W
    Moderator

    @robin-w

    “deactivating all plugins tangentially related to bbpress ”

    The plugin conflict has nothing to do with whether the plugin is related to bbpress – any plugin can cause a conflict.

    This is because conflicts are often with common variable names such as $user, where one plugin may set it to be x and the other uses it expecting it to be y.

    Disable all plugins, and switching to a default theme proves that both wordpress and bbpress are correctly installed (ie not corrupt). From there you can add back themes and plugin to work out which is causing the conflict.

    “There are a number of related threads about this issue on the forum but none have any real solutions provided.”

    There are tens of thousands of plugins, and thousands of themes, and conflicts will occur with combinations of these. There is not one common problem here, the symptoms are the same but the causes many, so “real” solutions are individual. In the last few weeks solutions for many including a caching plugin and a theme have been posted.

    Your problem is individual to you.

    Try again with getting to a root cause by disabling all plugins and going to default theme, and come back if you still have a problem, we’ll try to help you to resolve this.


    ecoportaluk
    Participant

    @ecoportaluk

    Hi Karen,
    My issue was self-inflicted. I’m using S2 member to restrict access to my forums and I checked one to many boxes in the restrict view config. It wasn’t obvious to me that the restriction would impact specific aspects of a user in bbpress, I was intending an all or nothing approach to user access. It is definitely a frustrating issue to try and resolve. All I can suggest is check any user restrictions you have in user roles as there seems to be something strange happening in accessing specific views of topics and replies. By strange I mean difficult to debug. Still not sure why you should be able to configure it so that a user could not view the topic details but could reply! Good luck and I hope you resolve your issue.

    Cheers

    Dave


    nerak_d
    Participant

    @nerak_d

    This ended up being a conflict with a plugin associated with PaidMembershipPro, and the whole process of deactivating every plugin and then patching the site’s functionality back together, plugin by plugin, did identify the conflict and solve the problem. Thanks very much to both Robin & Dave for their help. It took awhile but now it’s working again!


    ecoportaluk
    Participant

    @ecoportaluk

    Glad you got it sorted. I bet your feeling better now!

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.