Skip to:
Content
Pages
Categories
Search
Top
Bottom

The Display Name stopped working

  • Upgraded to the lastest bbPress and find that the display name has stopped working… was using the display-name plugin… for this

Viewing 17 replies - 1 through 17 (of 17 total)
  • Darn… the view only on login plugin is also not working you can see the club without logging in.

    Post a link to the plugin you are using or the code for it. We can fix it quickly here for the login only plugin. The display name is on the plugins site. We can fix that one after fixing your Important issue first.

    Trent

    Hmm…if it is this one, it might be tougher for me to figure out without help!

    http://bbpress.org/plugins/topic/27?replies=1

    Trent

    Trent… don’t remember where I picked it from it’s called the Force-login… did someone here give me the code and I copied and pasted it… not sure… here’s the code…

    <?php
    /*
    Plugin Name: Force Login
    Description: No one can see your forums unless they are logged in.
    Plugin URI: http://bbpress.org/forums/topic/117
    Author: Michael D Adams
    Author URI: http://blogwaffe.com/
    Version: 0.7
    */
    function force_login_init() {
    if ( !bb_is_user_logged_in() && false === strpos($_SERVER['REQUEST_URI'], 'bb-login.php') ) {
    if ( file_exists( BBPATH . 'my-templates/login.php' ) ) {
    require( BBPATH . 'my-templates/front-page.php' );
    } else {
    require( BBPATH . 'bb-templates/front-page.php' );
    }
    exit;
    }
    }
    add_action( 'bb_init', 'force_login_init' );
    ?>

    Haven’t checked it the bbpress-integration (bbpress-wp same users share) is working or not.

    What is your theme name….we can fix this in a hurry for you! Is it the default theme now?

    Trent

    I have several plugins with 0.8 and the integration plugins work fine. Memberlist, Private Messaging, (this one) and a few others. Only ones that reference the templates or specific files in themes….rest work fine.

    Trent

    Hey, that’s me! :)

    Try this:

    <?php
    /*
    Plugin Name: Force Login
    Description: No one can see your forums unless they are logged in.
    Plugin URI: http://bbpress.org/forums/topic/694
    Author: Michael D Adams
    Author URI: http://blogwaffe.com/
    Version: 0.7
    */

    function force_login_init() {
    if ( !bb_is_user_logged_in() && false === strpos($_SERVER['REQUEST_URI'], 'bb-login.php') && false === strpos($_SERVER['REQUEST_URI'], 'bb-reset-password.php') ) {
    bb_load_template( 'login.php' );
    exit;
    }
    }

    add_action( 'bb_init', 'force_login_init' );

    ?>

    It’s the default theme… all righty mdawaffe is here… thanks… I’ll update this and let you guys know…

    Will the bbPress-WP Integration be working?

    There is no reason why it will not. Mine is working and has been since the functions of 0.8 began in TRAC and continue on with the upgrade to 0.8 today.

    Trent

    Error on trying forcelogin

    Warning: force_login_init(/home/ozdesi/public_html/passionforcinema-com/club/bb-templates/front-page.php) [function.force-login-init]: failed to open stream: No such file or directory in /home/ozdesi/public_html/passionforcinema-com/club/my-plugins/forcelogin.php on line 15

    I am sure Micheal can fix this quickly, but maybe try this until he gets around to it:

    <?php
    /*
    Plugin Name: Force Login
    Description: No one can see your forums unless they are logged in.
    Plugin URI: http://bbpress.org/forums/topic/117
    Author: Michael D Adams
    Author URI: http://blogwaffe.com/
    Version: 0.7
    */
    function force_login_init() {
    if ( !bb_is_user_logged_in() && false === strpos($_SERVER['REQUEST_URI'], 'bb-login.php') ) {
    if ( file_exists( BBPATH . 'my-templates/login.php' ) ) {
    require( BBPATH . 'my-templates/kakumei/front-page.php' );
    } else {
    require( BBPATH . 'bb-templates/kakumei/front-page.php' );
    }
    exit;
    }
    }
    add_action( 'bb_init', 'force_login_init' );
    ?>

    I just hardcoded the new template directory. Not a long term fix. mdawaffe will have a fix soon enough!

    Trent

    Thanks Trent.!!!

    Since the plugin I put up here: http://bbpress.org/forums/topic/694?replies=13#post-4202

    doesn’t make any reference to front-page.php, I do not know why you are getting that error.

    Are you sure you were runnig the version I put up? Do you have multiple versions of the same plugin running?

    No I don’t… I’ll try again… in a few and let you know how it goes.

    I’m stumped then. You win the prize :) !

    I may have done something wrong… I deleted the whole folder and uploaded it again with the modified plugin… and it is working!!!

    Is it me or some weird odd reason the display name seems to show up exactly like the previous version… no problems now…

    After I log in I enter a different page (I think it’s the admin page) instead of the forums… is that how it is supposed to be?

    this is weird… logged out logged in about 2-3 times… tried to log in as another user… error… logged in again as me (admin) and this time I went straight to the forums instead of the dashboard.

Viewing 17 replies - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.