Skip to:
Content
Pages
Categories
Search
Top
Bottom

Successful install, but where is the administration area?


  • globetrotterdk
    Member

    @globetrotterdk

    Help, please. A very basic question, maybe a sticky would be a good idea? I have successfully installed and integrated the latest alpha version (as of today) with WordPress 2.6.3, (congratulations to the team) but I can’t figure out how to get into the administration area.

Viewing 25 replies - 1 through 25 (of 39 total)

  • chrishajer
    Participant

    @chrishajer

    When you log in as keymaster, right next to your name will be a link to “Admin” – that’s the admin section.

    If you have logged in, and you don’t have that link next to your name and instead have just “View your profile”, then you’re not the keymaster and the permissions have somehow gotten jazzed up.


    globetrotterdk
    Member

    @globetrotterdk

    I have an “admin!” link, an “Admin” link and then a “Log Out” link. When I finished installing bbPress, I got the following message:

    “Once you have finished installing, you should visit the WordPress integration section of the bbPress admin area for further options and integration instructions, including user mapping and the correct cookie settings to add to your WordPress configuration file.”

    The only thing that I can see that I can do in the Admin area is to add a new topic. I don’t see anything like what was described in the message.

    Lastly, how do I place a http://www.site_name.whatever/forums/ link to the forum next to the pages links in the header and footer of my WordPress site? I tried placing it next to <?php wp_list_pages(‘title_li=&depth=1′); ?> but then everything went blank on the site.

    Cheers


    chrishajer
    Participant

    @chrishajer

    Please post a screenshot of your admin screen after you log in and click Admin. There are normally more options than what you’re describing. I think they are “Users”, “Manage” and “Design” on the left, then a couple more on the right (settings and plugins.)

    For how to place a link to the forum in your WordPress site, that’s highly dependent on your theme. But a basic html link will normally work, depending on where you’re putting it.

    <a href="http://www.example.com/forums/">Forums</a>

    If you’re putting it near wp_list_pages, in an unordered list, then it needs to be wrapped in li tags.

    <li><a href="http://www.example.com/forums/">Forums</a></li>


    globetrotterdk
    Member

    @globetrotterdk

    OK, the screenshot can be obtained here:

    http://snipr.com/4xgrn-pz7znq

    Cheers


    chrishajer
    Participant

    @chrishajer

    OK, the little “admin” is your username, the big “Admin” is the link to your administration area. That’s the screenshot I am looking for – when you click “Admin” what does the screen look like. Does it look like this?

    http://www.chrishajer.com/bbpress/admin-dashboard.png


    globetrotterdk
    Member

    @globetrotterdk

    Hi,

    No, the screenshot is what it looks like when I click “Admin”


    chrishajer
    Participant

    @chrishajer

    Then something is not working :-)

    I had that problem when I buggered the cookies in my bb_config file, while trying to integrate WP and BB. Double check that that’s set up right.


    globetrotterdk
    Member

    @globetrotterdk

    I don’t see anything with cookies in the bb-config.php file. Are you referring to the authentication keys? If so, my keys are set correctly.

    Yeah, the authkeys, sorry, been a hell of a weekend.

    You have same AUTH_SALT and LOGGED_IN_SALT set as you do on your WP config?


    globetrotterdk
    Member

    @globetrotterdk

    How do I check this? I can’t seem to get to the settings page that included AUTH_SALT and LOGGED_IN_SALT

    I follow this with great interest since I have almost the same problem. I dont even see the admin admin, I only have one admin and that is my account since if I try to use it I get to edit my profile. I’ve tried entering the path http://www.zulan.se/bbpress/bb-admin/ but it only takes me to the first page :-(

    I have checked my AUTH_KEY, SECURE_AUTH_KEY AND LOGGED_IN_KEY and they are for sure the same since I havent changed them. So both my wp and bb config says like this:

    define(‘AUTH_KEY’, ‘put your unique phrase here’); // Change this to a unique phrase.

    define(‘SECURE_AUTH_KEY’, ‘put your unique phrase here’); // Change this to a unique phrase.

    define(‘LOGGED_IN_KEY’, ‘put your unique phrase here’); // Change this to a unique phrase.

    globetrotterdk, you have to look into your wp-config.php file.

    On bb-config.php I added in:

    define('AUTH_SALT', 'AUTHSALT');
    define('LOGGED_IN_SALT', 'LOGGEDINSALT');

    Which is exactly the same as in my wp-config.php file. And, obviously, it’s not actually set to AUTHSALT but something like UYwE&#93&We3#

    Just like Globetrotterdk I dont have AUTH_SALT and LOGGEDINSALT at all in my wp-config.php. I created a lab site just to check and it’s not there either. I’ll try and just enter in manually into both of the config files.

    Nah, still didnt work. If I dont use require_once(‘../wp-blog-header.php’); I cant get to the admin page, it just redirects to the bbpress frontpage. And if I use it, I get:

    Warning: require_once(../wp-blog-header.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/www.zulan.se/bbpress/bb-config.php on line 41

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-blog-header.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/www.zulan.se/bbpress/bb-config.php on line 41


    globetrotterdk
    Member

    @globetrotterdk

    I don’t have any AUTH_SALT and/or LOGGED_IN_SALT in my wp-config.php file.


    chrishajer
    Participant

    @chrishajer

    Zulan: this error says you have the path to the file wrong in your bb-config.php.

    Warning: require_once(../wp-blog-header.php)
    [function.require-once]: failed to open stream:
    No such file or directory in
    /var/www/www.zulan.se/bbpress/bb-config.php
    on line 41

     

    What path do you have listed to wp-blog-header.php on line 41 in your bb-config.php?


    chrishajer
    Participant

    @chrishajer

    globetrotterdk: I don’t know that they normally are in the wp-config.php file. You need to pull the options from the database using this URL:

    http://www.example.com/wp-admin/options.php

    Search that page for “salt” and you’ll see the settings WordPress is using.


    globetrotterdk
    Member

    @globetrotterdk

    Cheers. OK, I have added the bits:

    define(‘AUTH_SALT’, ‘AUTHSALT’);

    define(‘LOGGED_IN_SALT’, ‘LOGGEDINSALT’);

    I filled in the correct values, but still no change in the Admin view.


    globetrotterdk
    Member

    @globetrotterdk

    OK, I guess I should modify that last posting. I now have tabs off to the right called “Profile”, “Edit” and “Favorites”. I still don’t see any WordPress integration section of the bbPress admin area, however.


    chrishajer
    Participant

    @chrishajer

    Clear your cookies or use another browser and see if that helps.


    globetrotterdk
    Member

    @globetrotterdk

    Nope, I did both and the situation is the same.

    Chrishajer: Thanks for helping out. I have tried clearing the cache and I’ve tried both IE7 and FF3, doesnt change anything.

    Regarding the path, line 41 says:

    require_once(‘../wp-blog-header.php’);

    I have tried using this instead:

    require_once(‘/var/www/www.zulan.se/wp-blog-header.php’);

    And then the error goes away, but as soon as I press the “Admin” link next to my login name and Log Out it just takes me back to the first bbpress page located at http://www.zulan.se/bbpress/


    chrishajer
    Participant

    @chrishajer

    Yes, sometimes the full path is required rather than a relative path. At least you have resolved that problem. The other problem I do not know about. Can you have a look at the database for the bb_usermeta (or wp_usermeta if you’re integrated) and see that the value is for the admin/keymaster user?

    Ok, I’m not sure wich value you need so I’ve copied all the admin stuff from the db, I’m integrated so this is wp_usermeta.

    1 1 nickname admin

    2 1 rich_editing true

    3 1 admin_color fresh

    4 1 wp_capabilities a:1:{s:13:”administrator”;b:1;}

    5 1 wp_user_level 10

    21 258 admin_color fresh

    20 258 rich_editing false

Viewing 25 replies - 1 through 25 (of 39 total)

You must be logged in to reply to this topic.