Skip to:
Content
Pages
Categories
Search
Top
Bottom

Subscribers unable to write topics & add images


  • CathieHeart
    Participant

    @cathieheart

    Hello,

    I’m struggling to get a new subscriber user I created to test functionality and found that they are unable to upload pictures / files. I understand that only users who are able to upload media will be able to add new media but I’ve edited the access rights to allow subscribers to upload their own media.

    I’m using:
    Wordpress: Version 3.9.1
    bbPress: Version 2.5.3
    bbPress Enable TinyMCE Visual Tab: Version 1.0.1 –

    I’ve setup a fresh install of wordpress and I’m running a minimum of plugins, user switching, bbpress, bbpress genesis and the bbPress Enable TinyMCE Visual Tab plugin. I’m also using a plugin by WP-Types called Access to that I’ve used to make a subscriber able to read, edit, delete and publish their own media files.

    How do I get the basic subscriber user to be able to:

    • create a topic
    • reply to topics
    • be able to upload media as a forum participant

    I’ve got the settings > forum > set to ‘Automatically give registered visitors the Participant forum role’. What else do I need to do?

    Thanks
    Cathie.

Viewing 5 replies - 1 through 5 (of 5 total)

  • Robin W
    Moderator

    @robin-w

    go back into editing your user, and right near the bottom you’ll see a setting for the forum – check that this is correct for your users.

    If they are automatically being registered, then it should set to participant.

    If you are manually setting them up, then you need to go back into edit each time and set this level up.


    CathieHeart
    Participant

    @cathieheart

    yup this is correct. Their WP user roles are both set to Subscriber and also their Forum role is set to Participant.

    Still cannot created a topic, reply or add any media due to not being able to do the first two things.

    :S


    Robin W
    Moderator

    @robin-w

    I think you need to eliminate conflicts for instance maybe the access plugin is conflicting

    try

    Plugins

    Deactivate all but bbpress and see if this fixes. if it does, re-enable one at a time to see which is causing the error.

    Themes

    If plugins don’t pinpoint the problem, switch to a default theme such as twentytwelve, and see if this fixes.


    CathieHeart
    Participant

    @cathieheart

    Thanks Robin, I’d already deactivated everything other than bbpress and worked steadily from there. Everything worked except uploading images with just bbPress active.

    Then I activated just the single bbPress Enable TinyMCE Visual Tab plugin and it worked.

    It probably bamboozled me because when I started up at the beginning with just bbPress and that plugin I hadn’t found the ‘media button’ check box in the plugin settings! grr.

    So then I tried to be smart and add a user role management plugin which then messed everything up ever after.

    Sometimes I need the hint to go back to basics, just have one thing work and figure out the clash point!

    Cheers Robin!


    Robin W
    Moderator

    @robin-w

    great – glad you’re fixed !

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.