Skip to:
Content
Pages
Categories
Search
Top
Bottom

sidebar showing wp widgets although set up for bbpress widgets.


  • tony webb
    Member

    @tony-webb

    I’ve got the following page showing wp widgets in the side bar although i have published it with bbpress widgets in the sidebar.

    http://what-do-christians-believe.co.uk/wp/forums/

    I did have an earlier problem with 2 pages showing as the main root for the forum directory although 1 was deleted several days ago.

    the root was showing forums/forums.

    I’m now left with a forum list and the sidebars of an ?old deleted page and the page heading of the new page.

    is there a way to sort this out? Creating a new page didn’t work.

Viewing 3 replies - 1 through 3 (of 3 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Widgets are not “per page.” I don’t understand what’s wrong.


    tony webb
    Member

    @tony-webb

    Thanks for your reply. It’s a bit difficult for me to explain without you seeing how I’ve set up the forums page layout. I’ll try again.

    My forum is integrated with wp.

    For this I created 2 menus one for the blog and one for the forum.

    All the blog pages have a blog sidebar and appear as they should.

    All the forum pages have forum sidebars and appear as they should except for the forum lists page (main page) that still has the blog sidebars.

    I have set the template for this page as bbpress forums (index)

    The problem is that I have set the forum lists page (my main page) to show the forum side bar but it still shows the blog sidebar.

    If you look at these three links it will show what I am trying to explain. (I’m currently building this forum. You can’t see it from the main menu)

    http://what-do-christians-believe.co.uk/wp/ (blog set up)

    http://what-do-christians-believe.co.uk/wp/forums/ (page with wrong menu)

    http://what-do-christians-believe.co.uk/wp/forums/announcements (forum set up)

    I have tried changing the default sidebar in the settings > sidebar but that doesn’t work either.

    All I was doing was following the video instructions. He mentions that you should put the forums index etc on a page as you get better editing options.

    I haven’t put the forums, topics or posts on a page yet because of this problem


    tony webb
    Member

    @tony-webb

    I’ve resolved this issue by messing around with the default side bar settings and inserting custom sidebars.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.