Skip to:
Content
Pages
Categories
Search
Top
Bottom

Search function


  • batmanfan
    Participant

    @batmanfan

    Just wondering on the ‘search’ function. I’ve created a ‘hidden’ forum only for selected users. This forum is not visible to non-logged in users, but when they search for keyword on the hidden forum, it still display the topic in the hidden forum. It shouldn’t display anything on the ‘hidden’ forum or topic right? Have I missed something? Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)

  • batmanfan
    Participant

    @batmanfan

    Oops it seems the ‘search’ feature can find anything by anyone (logged-in or out visitors), it even finds topics/replies on PRIVATE/HIDDEN forum!

    Also, the tags widget on private and hidden forum also direct to the private/hidden topics/replies too :(

    How to make private/hidden forum/topic/reply – private? and can’t be searched/found by any visitor? Thanks.


    Stephen Edgar
    Moderator

    @netweb

    This forum is not visible to non-logged in users, but when they search for keyword on the hidden forum, it still display the topic in the hidden forum.

    I cannot reproduce this, any topics in hidden or private forums are not shown in the search results.

    Oops it seems the ‘search’ feature can find anything by anyone (logged-in or out visitors), it even finds topics/replies on PRIVATE/HIDDEN forum!

    Same, I cannot reproduce this, any topics in hidden or private forums are not shown in the search results.

    Also, the tags widget on private and hidden forum also direct to the private/hidden topics/replies too :(

    What ‘tags widget’ are you using? bbPress does not include a tags widget.


    batmanfan
    Participant

    @batmanfan

    Oh, what did I do? what did I do? it seems fine now, search can’t find the hidden/private topic now. Still can’t believe what happened especially on the ‘private’ topic, I tested and tested it showed to anyone searching for it. But now it’s ok.

    Stephen, thank you so very much for the great support. You must have helped me to changed something by accident to make it work now. Thank you thank you!

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.