Skip to:
Content
Pages
Categories
Search
Top
Bottom

removing tags

  • When I clicked as admin on the small cross next to a tag in a topic to remove the tag, it would not let me do it. Got message that tag has not been removed. Is there another way of doing it?

    Thank you.

Viewing 25 replies - 1 through 25 (of 32 total)

  • chrishajer
    Participant

    @chrishajer

    That’s the best way of doing it. I think I would concentrate on why it wouldn’t allow you to do what is a normal function in bbPress.

    I tried it again today and I keep getting the same message that tag was not removed and click to go back to forums. Where do I start to investigate? The other way might be to delete the entire topic with its tags? Does deleting a topic automatically delete tags associated with it too?

    Thanks.


    chrishajer
    Participant

    @chrishajer

    Can you post a link to your forum where someone can see the problem?

    Are you using any plugins that might cause this?

    Maybe there’s a problem with your theme?

    How about AJAX and JavaScript? I think tag removal depends on JavaScript.

    I’m not sure if deleting a topic deletes the tags with it. I tend to think it doesn’t since there is an admin option to recount and find tags with no topics (stranded tags.) Also, bbPress would have to be smart enough to know if a tag was used only on that topic and no others. Maybe it’s that smart but I am guessing it doesn’t work like that.


    chrishajer
    Participant

    @chrishajer

    I just created a new topic and added a tag to it that does not exist elsewhere. Then I deleted that topic. Then I tried to access the tag page and it gave a 500 error. It almost looks like trying to access a page for a tag that does not exist always give a 500 error (at least here it does, anyway.)

    So, maybe deleting the topic DOES delete the tag that was associated with it?

    As a further test, I created a new topic and added an existing tag to it. Then I checked how many times the tag was used (297) and then deleted the topic and checked the count again and it was decremented to 296.

    Lost my train of thought there so I can’t be certain that I tested everything I meant to.

    I guess deleting a topic that has a unique tag deletes the tag, since trying to access the tag page gives a 500 error (or at least a blank screen.) And deleting a topic that had a tag that was used elsewhere doesn’t delete the tag, but does decrement the number of times the tag was used.


    Mark Waterous
    Member

    @delayedinsanity

    You might want to explore where that 500 is coming from, that probably shouldn’t happen. I did the same thing just to see if it was inherent to bbPress or maybe just bbPress.org, and it seems it might be just you. :) I got a blank page (would be nice to see that redirect somewhere else for non-existent tags) but it was showing a 200 ok, and not a 500.

    I just realized bbPress doesn’t have anywhere to view/edit tags in the administration panel. Is that coming down the road?


    chrishajer
    Participant

    @chrishajer

    I didn’t actually check the code, if it was 200 or 500. I just assumed the blank page was due to a 500 error. It would be nice to see “sorry that tag does not exist” or something on an error page.

    Try to browse a non-existent tag here and see what happens.

    Just checked here and it’s a 200 response with a blank page. My information about 500 error earlier was incorrect.


    Mark Waterous
    Member

    @delayedinsanity

    Looks like it’s bb_repermalink that’s choking and causing us to get that blank page.

    Submit to trac? You can modify the following in functions.bb-core.php, starting on line 737;

    $_original_id = $id;
    if ( !$id )
    $permalink = bb_get_tag_page_link();
    else {
    global $tag, $tag_name;
    $tag_name = $id;
    $tag = bb_get_tag( (string) $tag_name );
    $permalink = bb_get_tag_link( 0, $page ); // 0 => grabs $tag from global.
    }

    To;

    $_original_id = $id;
    $tag = bb_get_tag( (string) $id );
    if ( !$tag )
    $permalink = bb_get_tag_page_link();
    else {
    global $tag, $tag_name;
    $tag_name = $id;
    $permalink = bb_get_tag_link( 0, $page ); // 0 => grabs $tag from global.
    }

    And instead of returning that blank page, it will return the global tags page. Possibly not the most eloquent solution, but works nonetheless.


    chrishajer
    Participant

    @chrishajer

    It’s worth opening a trac ticket, I think.


    Mark Waterous
    Member

    @delayedinsanity

    I made an oops. That code above doesn’t work, and I edited it earlier but I forgot to hit submit (I have so many tabs open it’s not even funny).

    The proper code is as follows;

    $id = ( isset($_GET['tag']) ) ? $_GET['tag'] : false;
    if ( ! $id || ! bb_get_tag( (string) $id ) )
    $permalink = bb_get_tag_page_link();
    else {
    global $tag, $tag_name;
    $tag_name = $id;
    $tag = bb_get_tag( (string) $id );
    $permalink = bb_get_tag_link( 0, $page ); // 0 => grabs $tag from global.
    }

    …with the code I originally posted, there’s no tag information passed on, so you get a whole wheelbarrow full of nothing.

    Trac filed, #1197… first time I’ve ever filed a trac, so I hope I followed etiquette/protocol properly. ;)

    Thanks. What javascript do I check? Also where are the tags stored? Can they be deleted from within where they are stored? I am only using 2 plugins with the theme. One is for images and the other for attachments. Link to the forum is http://www.invictatrader.com/bbpress if you want to see it. Not sure it might help as you have to login as admin to delete tags? And presently I have all the tags with the topics intact. Have not removed a topic and left a tag.

    Thank you.


    Mark Waterous
    Member

    @delayedinsanity

    Sorry for trailing off topic there. Here’s a quick question, have you modified the template in any way? If the proper classes/ID structure is not in place on the html side of things, the javascript will not have anywhere to hook into to make the AJAX updates. Could be the problem if you accidentally removed a class declaration somewhere.

    Have not touched the template in any way.

    i have the same prob – can’t delete tags. lots of plugins, no template alts

    Where are the tags stored? Can they be deleted from within where they are stored in a file on the server?

    Thanks.

    Everything dynamic in bbPress/WordPress is stored in the database, and tags are stored in one table but referenced in others. Better to fix the underlying problem.

    Anyone else havng problem deleting tags? Something not done too often to realize the problem I guess.


    chrishajer
    Participant

    @chrishajer

    I delete tags here all the time and it works fine. Your issue is unique and uncommon., I think.

    Where is the function code to delete tags? Maybe I can look at that and check to see if it right or missing.

    Thanks.

    Anyone else having the problem of deleting tags within the “Structure” theme? Can I check for that code somewhere that deletes tags?

    Thanks.


    chrishajer
    Participant

    @chrishajer

    Have you tried the stock theme to see if it is indeed the theme?

    Are you sure the JavaScript is being loaded the same between the default theme (or the theme here) and Structure?

    Did you ever post a link to your forum?


    jayvasdewani
    Member

    @jayvasdewani

    I tried it again today and I keep getting the same message that tag was not removed and click to go back to forums. Where do I start to investigate? The other way might be to delete the entire topic with its tags?

    http://www.jobsshell.com/


    chrishajer
    Participant

    @chrishajer

    jayvasdewani – what is the URL of the forum? That’s a pretty customized install from the looks of things and I can’t tell where bbPress is.

    hey chris. I tried it on a different theme from the bbpress showcase and the tags delete function works properly. The URL is http://www.invictatrader.com/bbpress FYI. What is the stock theme? The default theme?


    chrishajer
    Participant

    @chrishajer

    Yes, I meant the default theme, kakumei.

    So, it’s a problem with your theme.

    I created an account and posted a test topic. I don’t even see the little X next to the tag to delete it. So, how are you going about deleting tags? Normally, you get a little X next to any tag you use so you can delete your own tags.


    chrishajer
    Participant

    @chrishajer

    Here is a screenshot of the little [x] next to the tags I can delete here:

    http://chrishajer.com/bbpress/remove-tags.png

    Why is that not present in your theme?

Viewing 25 replies - 1 through 25 (of 32 total)

You must be logged in to reply to this topic.