Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problems with Pretty Permalinks with version 1.0.1

  • Has anything changed with with the steps for setting up Pretty Permalinks on bbPress 1.0.1?

    I have tried the methods in the FAQ, without success, on two different webhosts (Media Temple & Bluehost).

    Adding a .htaccess file with “Options +MultiViews” results in an error message when I try to load any page in the forum. When I try to visit “/bb-admin/rewrite-rules.php”, it redirects to the permalink settings page, and I do not see any code being generated that I could add to my .htaccess file instead.

    I have bbPress installed in a subdirectory with WordPress in the root directory. I have Pretty Permalinks functioning just fine in WordPress.

    Have I missed anything obvious here?

Viewing 7 replies - 1 through 7 (of 7 total)

  • incirus
    Member

    @incirus

    I dont know if it helps but I had the permalinks problem after converted from phpBB.

    I solved the problem by correcting the “topic_slug” fields for each topic in topics table.


    chrishajer
    Participant

    @chrishajer

    With 1.0.1, the rewrite rules were added to the .htaccess for me. Check your .htaccess and see if the rules are already there. If not, maybe bbPress could not write to the file.


    splebly
    Member

    @splebly

    i’ve been battling with the Pretty Permalinks for a while now too. Same situation as jleuze. No rewrite rules were generated and the rewrite-rules.php take me to the setting page. i found some examples of the rules in the forum, i copied em and the “Numeric” Permalink type works ok, but not the name based type.

    Thank you for the info, it was very helpful!

    @chrishajer – I checked my .htaccess file, and the permissions were incorrect, II tweaked that, and bbPress added the rewrite rules without issue.

    @incirus – Yes, my forum is converted from phpBB as well, I don’t know why I didn’t think of that before. I checked a new topic, the pretty permalink worked just fine. I checked an old topic in the database, no slug. i added a slug and it worked great.

    Unfortunately I have 875 topics that I would have to edit my hand… That’s too bad, one of the draws of migrating to bbPress are the useful permalinks.

    Has anyone out there come up with a handy script to solve this problem? I’d imagine the code is already there, since bbPress already converts your topic title into a slug, it would just be a matter of having it process all of the old titles. But I think that’s a bit out of my league!

    Hell, I’d settle for a way to use slugs from here in out, but fall back on the default permalinks if there is no slug, but I think that would be more complicated.


    incirus
    Member

    @incirus

    well, I used excel. here is the dummy script for excel

    trim(cell)

    replace blank, and all other unwanted characters with the underscore

    create your sql and you are good to go

    I couldnt find the perfect converter but I am so happy that I convert to bbPress.

    simplicity is the poetry


    incirus
    Member

    @incirus

    I forgot to say you can also create your sql query with the excel too

    Thanks for the tip incirus, I’ll check that out.

    Yeah there is something about the minimalism of bbPress that I find very liberating!

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.