Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problems bbPress1 migration


  • castresana
    Participant

    @castresana

    Hello everybody!

    I have a bbPress 0.9.0.7 forum running that works great. http://elanillounico.com/v5/foro
    It has it’s users linked to my WordPress 3.4.2. http://elanillounico.com/

    I wanted to migrate the bbPress to bbPress 2.1.2 (actual version) but I guess I am doing something wrong.
    The new url for the forum is: http://elanillounico.com/forums

    WHAT I AM DOING…

    First of all I’m installing bbPress 2.1.2 plugin and I activate it in my WordPress.

    Second I go to Tools – Forums – Import Forums, I select the bbPress1, I insert the db options and select all the options that suit my server so it doesn’t overload.

    I start the process and I wait until it finishes saying “No tags to convert” and then… I am getting this error :(

    WordPress database error: [Table 'my_database_forum.bb_term_relationships' doesn't exist]
    SELECT convert(term_relationships.object_id USING "utf8") AS object_id,convert(term_taxonomy.term_taxonomy_id USING "utf8") AS term_taxonomy_id,convert(terms.name USING "utf8") AS name FROM bb_term_relationships AS term_relationships INNER JOIN bb_term_taxonomy AS term_taxonomy USING (term_taxonomy_id) INNER JOIN bb_terms AS terms USING (term_id) LIMIT 0, 1000

    Apart from this, the installation does not go right. When I go to my forums, the forums themselves are all right. But the topics are all mixted up. It looks like if the answers to the original topics are now topics as well, so I have the forums with all of the messages as if they were topics, they are not linked as if they were lost the id that linked them.

    Any idea of what this means and why this happened??

    Question I have: Do I have to upgrade first to version bbPress 1.1 before I upgrade to bbPress 2.1.2?

    Thank you very much! :-)
    Juan C.

    • This topic was modified 1 year, 11 months ago by  castresana. Reason: needed to complete the issue
Viewing 10 replies - 1 through 10 (of 10 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Exactly. You’ll want to update to bbPress 1.1 first.


    castresana
    Participant

    @castresana

    Thanks for the quick reply!

    I just updated the bbPress to 1.1 version (last one available in Legacy).

    After upgrading bbPress1 I tryed to import it from bbPress2.1.2 and this time, the importer didn’t give me any errors, but the importation didn’t go right.

    The result is having the forums okay but in the transition the posts and replies are mixted up.
    It looks like the script has converted all the replies into new posts, and actually, it has not maintained the post/reply respective users, now all of the posts and even the replies of the original post (that now are new posts as well, not considered as reply), are written by first post user.

    So if we go to http://elanillounico.com/v5/foro/topic.php?id=9454#post-312800
    (this is the original forum, not it’s a bit mixted up, it’s the template),

    Anyway, in the lopic we saw, the user Aragorn_II began a topic and Wolfimbul replied and some other users as well.

    When we go to but that thread in the new forum for example, you have this forum view:
    inside a forum view

    So when you are entering first post available on the list, it is the original topic:
    original post

    And when you enter the second post available, you see the first reply, and it is written by Aragorn_II but it should be written by Wolfimbul.
    reply considered as new post

    So, in the end, I do not know what I am doing wrong, any ideas?

    Thank you!


    castresana
    Participant

    @castresana

    Just tried again and the reply the window gives me is:


    Repair any missing information: Continue

    Conversion Complete

    No replies to convert

    No tags to convert

    Converting topics (47000 - 47999)

    Any ideas? Thanks!

    Did you run ‘Repair Forums’ after the import?

    http://codex.bbpress.org/repair-forums/

    Is this the correct URL for your new forums? httpp://elanillounico.com/forums


    Markus Pezold
    Participant

    @markus-pezold

    Hi castresna,

    i’ve the same problem you describe above. After importing from bbPress 1.2 the replys and topics are mixed up. I’ve tried it a ten times – but no results.

    How have you solved this problem for your forum?

    I appreciate any advice. :)
    Thanks.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You’ll want to fully update to bbPress 1.1/1.2 first. Make sure your forums work after having done so. As long as the 0.9 to 1.1 migration was successful, moving to 2.x should be exactly as described above.

    The data schema changed from 0.9 to 1.1, and the converter in 2.0 is not for 0.9.


    Markus Pezold
    Participant

    @markus-pezold

    Hi John,

    in my situation is the correct version not the problem.
    The original forum is on version 1.1 since months. And updated to 1.2 yesterday.
    It’s an old forum (since 2002) – migrated to bbPress 0.9 and then 1.0 -> 1.1.
    Since May 2011 the forum was deactivated – after some problems with an user. :(

    Hmmm… I think the problem may lie in the fact that the forum has a lot of anonymous posters. In 0.9 there was an plugin for anonymous posters with meta data. But in version >0.9 these posts were all anonoymous posts without an user.

    I’ll test the convertion on a blank installation of WordPress 3.5 today (without any other plugins). And the i’ll report again.

    By the way. JJJ – carry on with your great work on bbPress. :)


    Markus Pezold
    Participant

    @markus-pezold

    Hi JJJ,

    after studying the bbPress 1.1 converter code and an deep look into the mySQL data I know the error. In my installation the field post_position is set for all old post to ’0′. It’s possible that this is an error form the originally convert from phpBB to bbPress 0.9 some years ago.

    From the import:
    ‘join_expression’ => ‘USING (topic_id) WHERE posts.post_position IN (0,1)’

    So for now – i’m searching for an solution to reset the post_position.


    Markus Pezold
    Participant

    @markus-pezold

    Alright. Everything fixed. ;)

    To set the post positions new​​, I created a curious script using the function ‘bb_update_post_positions’ and an sql-query to get all topics by id. I loop through the topics and make an function call for an modified ‘bb_update_post_positions’.

    I describe here only my approach to solve the problem. My php code itself could be dangerous. :)

    But if someone has the same problems importing old data (bbPress 1.x)  I’ll help via email.

     

     

     

     

    Glad you hacked found both your problem and a solution :P

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.