Skip to:
Content
Pages
Categories
Search
Top
Bottom

problem with installation

  • I would like install bbpress but how can I trying i got this

    Deprecated: Assigning the return value of new by reference is deprecated in C:xampplitehtdocsbbpressbb-settings.php on line 186

    Deprecated: Assigning the return value of new by reference is deprecated in C:xampplitehtdocsbbpressbb-includesbackpressfunctions.wp-object-cache.php on line 108

    Deprecated: Assigning the return value of new by reference is deprecated in C:xampplitehtdocsbbpressbb-includesbackpresspomomo.php on line 171

    Deprecated: Assigning the return value of new by reference is deprecated in C:xampplitehtdocsbbpressbb-includesfunctions.bb-l10n.php on line 484

    Warning: Cannot modify header information – headers already sent by (output started at C:xampplitehtdocsbbpressbb-settings.php:186) in C:xampplitehtdocsbbpressbb-includesfunctions.bb-pluggable.php on line 232

    I have xammp and windows vista

    thank you for yout help

Viewing 5 replies - 1 through 5 (of 5 total)

  • chrishajer
    Participant

    @chrishajer

    I this where you’re going to run bbPress or is it a test installation? These are warnings that appear to be related to running on XAMP and do not normally occur in a production installation.

    Also, they’re just warnings. If you can turn off PHP warnings, I think you won’t have any more trouble. But if you’re going to be running this in a production environment on another server anyway, I would just install it there and not worry about these issues.

    I’m getting the same error, and I tried to ignore the error but I can’t login to my administration page.

    Are there any fixes to the problem?

    Thanks, Baylor


    MattRogowski
    Member

    @mattrogowski

    This is a bug, it’s because you’re using PHP 5.3.0 and the code on the lines it references has been deprecated in PHP 5.3.0 to be removed in PHP 6.0. What I’d do (and did do) is downgrade to PHP 5.2.11 until the code is fixed to be 5.3.0 compatible; I got the same errors when I had it on PHP 5.3.0, downgrading sorts it as it’s OK code for PHP 5.2.11. It’s very simple to downgrade on WAMP, I’m not sure how you’d go about it on XAMPP though. Turning off the errors will still work, yeah, because the code will still physically work with PHP 5.3.0, but it’s just letting you know it’s due to be removed.

    That’s for the four errors about deprecation, for the Cannot modify header information error, may be related to the PHP 5.3.0 errors too as the error in bb-settings.php is on the same line as the deprecated warning.

    Thank You Matt,

    It was annoying the hell out of me too. I just downgraded my WAMP to PHP 5.2.9 and it worked perfectly.

    Cheers

    Piardog


    Ben L.
    Member

    @nightgunner5

    Add this line to your bb-config.php:

    error_reporting( E_ALL & ~E_DEPRECATED );

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.