Skip to:
Content
Pages
Categories
Search
Top
Bottom

Pretty Permalink Goes To WordPress “Sorry” Page


  • ArrowJ
    Member

    @arrowj

    When I turn off pretty permalinks everything works great, but when I turn it on it tries to load the page as if it were part of my Wordpres blog and of course that post does not exist. I use advanced permalink structures in my WordPress blog so I’m not sure why this is happening. Any suggestions? I do not have my blog integrated with my forum (other than sharing the same db).

Viewing 5 replies - 1 through 5 (of 5 total)

  • ArrowJ
    Member

    @arrowj

    added .htaccess…problem solved


    RichBrown
    Member

    @richbrown

    ArrowJ, where did you add the .htacess file?

    I have one for WP.

    Is this a new one?


    chrishajer
    Participant

    @chrishajer

    You need to add a .htaccess file for bbPress. You generate the rules by going to your site, here (once logged in as keymaster):

    http://www.example.com/forum-directory/bb-admin/rewrite-rules.php

    Then, paste those rules into a .htaccess file in your forum root.


    RichBrown
    Member

    @richbrown

    I did that and it takes me back to the forum page.


    chrishajer
    Participant

    @chrishajer

    It’s possible that the .htaccess one level up (WordPress directory) is conflicting with this .htaccess. You can just turn off permalinks for now until you figure it out. If you’re intent on figuring it out to get permalinks working, you might want to spend some time browsing threads that are tagged identical to this one.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.