Skip to:
Content
Pages
Categories
Search
Top
Bottom

Plugins not activating in alpha


  • SteveG190
    Member

    @steveg190

    I’ve installed the latest trunk build (1651) along with WP 2.6 and installation went perfect, user integration works great. Everything seems fine, except when I try to activate a plugin, it activates (according to the activate/deactivate link) but it really doesn’t. No settings links in the admin menu, no effect anywhere in the forum, so there is no actual activation. I’ve tried replacing bb-admin/plugins.php and admin-functions.php with earlier versions from previous trunk installs that worked fine, but no effect. I don’t even get any error messages.

    Does anyone have a clue where I could look to figure this out?

Viewing 9 replies - 1 through 9 (of 9 total)

  • chrishajer
    Participant

    @chrishajer

    Which plugin are you talking about?


    SteveG190
    Member

    @steveg190

    Any plugin. None at all will work.


    chrishajer
    Participant

    @chrishajer

    I asked only because I was wondering what you expected to see and maybe I could try the same plugin.

    I installed the BB Attachments plugin

    http://bbpress.org/plugins/topic/bb-attachments/

    Activated it and was able to add attachments. So, either you have a different problem with all your plugins in your installation or the plugins you are trying to use aren’t compatible with the alpha release, or maybe they are being activated and they are mostly invisible (like Akismet.) BB Attachments is a good one because you can see if it’s working when you go to make a new post.

    Activating Akismet, BTW, gives me a new admin submenu called “Akismet Configuration:.


    SteveG190
    Member

    @steveg190

    I’ve tried doing four clean installs of rev1651 and in none of them have I been able to properly activate plugins. I’ve tried to enable everything from Akismet to mini-track to a simple plugin I made to allow more html tags. All the plugins I’m trying are the latest up to date and work on my rev1646 installation.


    chrishajer
    Participant

    @chrishajer

    I am using r1636 which is what alpha was when I installed it. Seems odd to me that the 1.0-alpha-1 tag would now be r1651, but maybe I just don’t understand subversion tags.

    Why not use the earlier release? Did you need something specific in r1651?


    chrishajer
    Participant

    @chrishajer

    Do you have access to server error logs where you could possibly see what’s being logged when you try to activate a plugin?


    sendano
    Member

    @sendano

    Well… Hm..


    SteveG190
    Member

    @steveg190

    Let me add that I’m doing all my testing/installing locally using Xampp. http://trac.bbpress.org/ticket/928 made me think that maybe I’m having the plugin issue because of this problem? Just a shot in the dark perhaps? I think I’ll try uploading the latest trunk to my website (run on a unix server) tonight and see if it’s different in that environment.


    Sam Bauers
    Participant

    @sambauers

    This is fixed in trunk and will be fixed in the next alpha release which will probably be in the next couple of days.

    http://trac.bbpress.org/ticket/924

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.