Skip to:
Content
Pages
Categories
Search
Top
Bottom

Permalinks Problem – rewrite-rules.php does not work

Viewing 11 replies - 1 through 11 (of 11 total)
  • That is correct. Take the output of that file and put that in your /stereopoly.de/forum/ directory. Multiviews works with most servers I have played with, but had to use the rewrite-rules.php for my latest server.

    Trent


    stereopoly
    Member

    @stereopoly

    it does not work so, too.do you mean just copying the “rewrite-rules.php” into the forum-root directory and then try to run it again? I have set

    $bb->mod_rewrite = true;

    and within my htaccess it’s still said

    Options +MultiViews

    and then i have to go to http://www.stereopoly.de/forum/rewrite-rules.php , ay?

    does not work :(


    _ck_
    Participant

    @_ck_

    Some servers do not support Multiviews.

    Try this:

    1. $bb->mod_rewrite = false;

    2. http://www.stereopoly.de/forum/bb-admin/rewrite-rules.php

    3. copy the list

    4. put the list into .htaccess

    5. remove Options + Multiviews

    6. $bb->mod_rewrite = true;

    Note the bb-admin in #2.


    stereopoly
    Member

    @stereopoly

    Thanks for your help, but it does not work :(

    Ā»No input file specifiedĀ«. So what now?


    chrishajer
    Participant

    @chrishajer

    Turn off permalinks and leave them off. Then see if your forum works.

    $bb->mod_rewrite = false; in config.php.


    stereopoly
    Member

    @stereopoly

    then it does work, yes but i’d love to have pretty permalinks :)


    chrishajer
    Participant

    @chrishajer

    One thing at a time. If everything works now, then you know you have a problem with the .htaccess and rewrite rules.


    _ck_
    Participant

    @_ck_

    Googling shows that error is caused when running PHP as a CGI and there is a mod_rewrite conflict (or a file does not exist).

    I suspect there is a conflict with mod_rewrite rules in the parent folder. Show us your rewrite rules in /.htaccess (probably wordpress stuff but there may be others).


    stereopoly
    Member

    @stereopoly

    this is what my htacces looks like in my root:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    RewriteEngine on

    RewriteCond %{HTTP_HOST} !^www.stereopoly.de$

    RewriteRule ^(.*)$ http://www.stereopoly.de/$1 [L,R=301]

    Redirect /feed feed://feeds.feedburner.com/stereopoly

    I have the same issue , and i think there’s a conflict between the two htaccess files!

    @stereopoly , does your forum work correctly with the existence of htaccess file in the forum folder ?


    chrishajer
    Participant

    @chrishajer

    ioloman please start a new topic. This one is 2 years old.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.