Skip to:
Content
Pages
Categories
Search
Top
Bottom

No Forum subscriptions (update to 2.5)


  • ihazparanoia
    Participant

    @ihazparanoia

    Hey there, I just updated to the newest version 2.5. I still can’t see the forum subscriptions (when I go to my account, there is just

    Subscribed Forum Topics
    You are not currently subscribed to any topics.

    Did I do something wrong?

Viewing 23 replies - 1 through 23 (of 23 total)
  • You need to subscribe to a forum for them to show up in your profile, the same with topics, you ned to subscribe to one to see them in your profile.


    ihazparanoia
    Participant

    @ihazparanoia

    Yeah but where? I can’t see any subscription function or button anywhere (just when I’m in a topic)..


    FreeWPress
    Participant

    @freewpress

    If you use a children template you must to add manually new link…

    <?php bbp_forum_subscription_link(); ?>


    FreeWPress
    Participant

    @freewpress

    I have updated to 2.5 version and add above subscription link… But.. no link show in page.. I have a child template in my theme path.. Why??


    FreeWPress
    Participant

    @freewpress

    Link must be placed in content-single-forum.php and it show link.. But when i click on subscrive link it works, but if you go in subscrived section in your profile it show: You are not currently subscribed to any forums.
    I have been updated user-subscriptions.php file with new code..

    is bad!! :/


    FreeWPress
    Participant

    @freewpress

    I have deactivate child template and using original bbpress template.. it not show any forum subscriptions only this: You are not currently subscribed to any forums.

    http://bbpress.trac.wordpress.org/ticket/2480 for this issue…

    http://bbpress.trac.wordpress.org/ticket/2480 has been updated with some more info.

    Also if you have a custom bbpress-functions.php in your theme that also needs to be updated.


    FreeWPress
    Participant

    @freewpress

    I don’t have any custom bbpress-functions.php in my theme and i have copy entire user-subscriptions.php in my child theme. And it not work… I see only: You are not currently subscribed to any forums.

    But i have subscribed three forums…

    Edit: Just read your reply on Trac

    Also check if you have a bbpress.php file in your child theme folder.


    FreeWPress
    Participant

    @freewpress

    yes topic subscriptions are ok.. it work fine..

    I don’t have bbpress.php in my child theme folder…


    Stephen Edgar
    Moderator

    @netweb

    @freewpress What happens when you use the standard Twenty Thirteen and/or Twenty Twelve theme?


    FreeWPress
    Participant

    @freewpress

    @netweb hi

    I have switched on twenty thirteen now.. Nothing change… Forum subscribed not show in user panel… If i go on forum subscribed i see link “unsubscribe” it works, but nothing show in subscriptions page.. Only topics… I think not is a my site problem..

    Other suggestions?


    Stephen Edgar
    Moderator

    @netweb

    Are you seeing the both subscriptions sections when viewing your user profile?

    eg http://127.0.0.1/forums/users/admin/subscriptions/


    FreeWPress
    Participant

    @freewpress

    Yes.. it’s same your screenshot but i see topics subscriptions… Only forums not show.. :(


    Stephen Edgar
    Moderator

    @netweb

    If you have switched to the Twenty Thirteen you should the same image that I posted above using bbPress 2.5.

    I know you have some custom templates in your normal themes child theme and I have a suspicion that you might also have some in your Twenty Thirteen theme folder and they need to be removed (or backed up), you need to find a theme that is ‘clean’ and has no extra additions in its folder structure, either in the root of the theme or a sub-folder bbpress.


    FreeWPress
    Participant

    @freewpress

    Stephen, Twenty Thirteen theme is clean, no customization , i never used this theme, folder is original no extra additions here…

    I see same image above with only difference wich i have subscribed 2 topics and see that.. But for forums i see only “You are not currently subscribed to any forums.”

    switched to the Twenty Thirteen remove all customizations for my theme and bbpress template.. it use all original files..


    FreeWPress
    Participant

    @freewpress

    Important NEWS in ticket.. see here http://bbpress.trac.wordpress.org/ticket/2480

    Issue is in subcategory forums…


    kriskl
    Participant

    @kriskl

    Hi, I am having the same problems,
    ( all subscribed forums are in subcategory )

    I did look in the track posts, as you mentioned,
    but I do not quite understand how did you resolve it please :)

    thank you for spelling it out for me


    FreeWPress
    Participant

    @freewpress

    You must to update at latest version 2.5.1 and resolve this issue!!


    kriskl
    Participant

    @kriskl

    Hi, I have updated, and I still have this problem.. :(


    kriskl
    Participant

    @kriskl

    I mean, it shows OK, subscribed topics. but not forums (it is just blank)


    leromt
    Participant

    @leromt

    I am having this same issue. I have a “parent” forum and then sub-forums under that parent, such as,

    Platoon Leader Forum
    — Additional Duties Forum
    — Supply Operations Forum
    — etc.

    If my users subscribe to the Additional Duties Forum and then check their subscriptions, the Additional Duties forum to which they just subscribed is not listed but instead the “parent” forum (Platoon Leader Forum) is shown and gives them the “+” symbol for them to subscribe to it but the Addition Duties sub-forum isn’t shown as having been subscribed to at all.

    I normally have the parent (Platoon Leader Forum) marked as a “Category” but even when I change it to back to a “Forum” I get the same results.

    I have a deadline pending to get this fixed. ANY help will be deeply appreciated.

    Tom


    leromt
    Participant

    @leromt

    For what it’s worth, here is what I ended up doing:

    1. I left my “parent” forum as a category.

    2. Around line 847 of bbpress/includes/forums/template.php, I added “true” to the if statement to force the “category” parent forum to be shown, as follows:

    // No link for categories until we support subscription hierarchy
     // @see http://bbpress.trac.wordpress.org/ticket/2475
    if ( true || bbp_is_forum_category() ) {
    $retval = bbp_get_user_subscribe_link( $r );
    }
    

    3. In bbpress/templates/default/loop-single-forum.php I replaced line 44 with the following:

    
    <?php 
    		
    $subForumList = bbp_forum_get_subforums();
    		
    if(sizeof($subForumList) > 1){
    
       echo "<ul style='margin-left: 20px;'>";
    
       foreach($subForumList as $currForum){
    
       // Create the arguments
       $r = bbp_parse_args( $args, array('forum_id' => $currForum->ID,
            'user_id' => 0,
            'before' => '',
            'after' => '',
            'subscribe' => __( 'Subscribe',   'bbpress' ),
            'unsubscribe' => __( 'x', 'bbpress' )
             ), 'get_forum_subscribe_link' );
    
        $isSubscribed = bbp_get_forum_subscription_link($r);
    
        // see if the returned html has 'is-subscribed' in it
        // if it does, then the user is subscribed to the forum
    
        if(strpos($isSubscribed, 'is-subscribed') != 0){
        echo "<li>" . $isSubscribed . "&nbsp;&nbsp;<a href='" . bbp_get_forum_permalink($currForum->ID) . "'>" . $currForum->post_title . "</a></li>";
        }
    			
       }
    
      echo "</ul>";
      } // end > 1
    ?>
    

    Feel free to criticize, pick apart, or provide feedback as you see fit…it works for me.

Viewing 23 replies - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.