Skip to:
Content
Pages
Categories
Search
Top
Bottom

@mention notifications not working, need help please.


  • George
    Participant

    @ridecbrcom-1

    My @mentions are not working anymore. I have had literally thousands of @mentions on my site, and never had a problem. Now it’s not giving any member a notification when someone @mentions them.

    Any ideas where to start troubleshooting?

    If you go to your profile or the activity stream and type in @admin I get a notification.

    Do it on the forums, no notification.

Viewing 7 replies - 1 through 7 (of 7 total)

  • enderandrew
    Member

    @enderandrew

    Isn’t this a Buddypress question, not a bbPress question?


    George
    Participant

    @ridecbrcom-1

    BBpress claims buddypress integration with the BBpress 2 plugin. @mentions are supposed to give members notifications out of the box. It worked in the past but I have NO idea why it’s not working now.

    You have both BuddyPress and bbPress installed/activated correct?

    What version of BuddyPress/bbPress?


    George
    Participant

    @ridecbrcom-1

    BBpress Version 2.0.3

    BuddyPress Version 1.5.6

    I did a plugin check and it’s not a plugin. Strange because if I mention myself on a wall or activity page, it sends me a notification. Do it on bbpress forum and it doesn’t give me anything.

    yes it is showing an error.


    psiggy
    Participant

    @psiggy

    @ridecbrcom
    Your problem is quite old now and maybe you’ve already solved it. Anyway, I’ve just run into this problem, so I’ll describe it (for anyone who will experience it in the future).

    How it behaves for most of the users (when it’s working):
    1) Install WordPress (during installation, allow search engines to index your site).
    2) Install Buddypress.
    3) Intall Site Wide Forums (bbPress).
    4) Create 2 users and create new bbPress forum.
    5) Try the mention functionality on the forum -> the user will be correctly notified about being mentioned.

    I’m almost sure this is the problem you’re describing:
    1) Install WordPress (during installation, deny search engines to index your site).
    2) Install Buddypress.
    3) Intall Site Wide Forums (bbPress).
    4) Create 2 users and create new bbPress forum.
    5) Try the mention functionality on the forum -> the user will not be notified about being mentioned.

    Another connected problem:
    1) Install WordPress (during installation, allow search engines to index your site).
    2) Change “WordPress address” and “Site Address” (this is not that unusual – especially when you’re moving your site from localhost to some valid place).
    3) Install Buddypress.
    4) Intall Site Wide Forums (bbPress).
    5) Create 2 users and create new bbPress forum.
    6) Try no mention one of the users -> the user will see the notification, but when he/she clicks on it, no mention will be displayed in the activity part.

    To sum up:
    – denying search engines from indexing your site will disable mention notifications from bbPress forums
    – changing WordPress and site address after the installation leads to empty mention list in the activity part (however, the notification in the toolbar will be displayed).


    palmdoc
    Participant

    @palmdoc

    Hi I am not denying search engines nor changed the site address yet I don’t have notifications when the user is mentioned in the forums with @username
    It’s working in the Activity stream though.
    Anyone else have similar problems?

    Buddypress 1.8.1, bbPress 2.4 and WordPress 3.6.1

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.