Skip to:
Content
Pages
Categories
Search
Top
Bottom

Latest plugin triggers fatal error–need to find older version


  • GlimmerGuy
    Participant

    @glimmerguy

    When I updated to the latest plugin version today it triggered a fatal error. We were updating because the forums had stopped showing any new posts since Dec. 16 and thought maybe an updated plugin might help. We are still using WordPress version 3.4.2 due to being in the middle of changing servers. My friend has requested that we go back to the previous plugin since at least the forums were showing up, albeit frozen, while she finds a bbPress expert. Problem is, I never had a copy of the bbPress plugin—I downloaded it from the WordPress Plugin site, which now shows only the most recent version. Can anyone tell me where I could find an earlier version of the plugin to download? Also, any thoughts where we can find someone to help us with our ongoing bbPress issues? Thanks very much.
    Website: http://thefriendshipblog.com

    Here is the error, which unfortunately is gibberish to me:
    Plugin could not be activated because it triggered a fatal error.
    Warning: require(/home/friendbl/public_html/wp-content/plugins/bbpress/includes/topics/functions.php) [function.require]: failed to open stream: No such file or directory in/home/friendbl/public_html/wp-content/plugins/bbpress/bbpress.php on line 303

Viewing 2 replies - 1 through 2 (of 2 total)
  • From that error it appears and is actually the case that not all of the files for bbPress were updated on your web host when you updated bbPress.

    - Make a backup of your site and database

    - Open your WordPress Admin Dashboard and go to Plugins

    - Deactivate the bbPress plugin (It should already be deactivated)

    - Delete the bbPress plugin and accept the confirmation that it will delete those files

    - Download the bbPress plugin again from the ‘Add New’ plugins section

    - Activate the bbPress plugin

    You should be all good to go now presuming this time your web host has downloaded and extracted all the files correctly to your site.

    ps. If you ever do need to download a current or previous version you can download them in .zip form to manually extract and upload via FTP to your web host via http://wordpress.org/extend/plugins/bbpress/developers/
    (The current version of bbPress at the time of writing is bbPress 2.2.3)


    GlimmerGuy
    Participant

    @glimmerguy

    Thanks for all the info, Stephen. Deleting and replacing the plugin did the trick. We’re not sure why the forum stopped showing posts dated after December 16, but at least it seems to be up and going again.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.