Skip to:
Content
Pages
Categories
Search
Top
Bottom

Issue with setting the database


  • WirelessTechie
    Member

    @wirelesstechie

    Hi all !

    I have issues setting the database at step 1 of the installation.

    I keep having the error message :

    “There was a problem connecting to the database you specified.

    Please check the settings, then try again.”

    I have added the rite details in my bb-config-sample.php (database name, username and PW)

    Moreover in the cpanel, i have correctly created the new database

    At step 1, i add the database name that i set on the config-sample file + in the DB definition in cpanel

    same for DB username and pwd

    but i still get the error message without much details. so i have no clue what the problem can be.

    Can you please help on that ?

    Thanks !

Viewing 10 replies - 1 through 10 (of 10 total)

  • iamanasha
    Member

    @iamanasha

    Here is the info that I got from my hosting provider. I hope that it helps.

    I use Hostgator. I do not know if it is the same across hosting providers. If you have trouble with these instructions, then contact your own hosting provider.

    1. Go to the Cpanel for your hosting provider.

    2. Under databases, select MySQL Databases

    3. First Option is Create New Database

    4. Just put the name you want in the box and hit create.

    5. Add New User to the new database you just created.

    6. Then you need to add that user to the database with all permissions.

    7. And then use that info during the install.


    iamanasha
    Member

    @iamanasha

    Here is the info that I got from my hosting provider. I hope that it helps.

    I use Hostgator. I do not know if it is the same across hosting providers. If you have trouble with these instructions, then contact your own hosting provider.

    1. Go to the Cpanel for your hosting provider.

    2. Under databases, select MySQL Databases

    3. First Option is Create New Database

    4. Just put the name you want in the box and hit create.

    5. Add New User to the new database you just created.

    6. Then you need to add that user to the database with all permissions.

    7. And then use that info during the install.


    WirelessTechie
    Member

    @wirelesstechie

    i am with hostgator too :)

    thanks! that’s what i did. i dunno why it cant work.

    pff…i thought that was easy to install….

    thinking of going back to the good old PHP BB…


    WirelessTechie
    Member

    @wirelesstechie

    i am with hostgator too :)

    thanks! that’s what i did. i dunno why it cant work.

    pff…i thought that was easy to install….

    thinking of going back to the good old PHP BB…


    WirelessTechie
    Member

    @wirelesstechie

    do you upload the bb-config or bb-config-sample file into your bbpress folder ?

    i ULed the sample one with the db name, user name and pwd that i configured in the cpanel.

    is that correct ?


    WirelessTechie
    Member

    @wirelesstechie

    do you upload the bb-config or bb-config-sample file into your bbpress folder ?

    i ULed the sample one with the db name, user name and pwd that i configured in the cpanel.

    is that correct ?


    WirelessTechie
    Member

    @wirelesstechie

    ok, i managed to install bbpress using the quickinstall item from the cpanel.

    it took just 5 sec. :)

    the bb-config file is set just like i did manually before, so i still wonder why it didnt work previously…


    WirelessTechie
    Member

    @wirelesstechie

    ok, i managed to install bbpress using the quickinstall item from the cpanel.

    it took just 5 sec. :)

    the bb-config file is set just like i did manually before, so i still wonder why it didnt work previously…


    iamanasha
    Member

    @iamanasha

    Sorry, I didn’t get back, I was MIA. Glad you got it resolved. :)


    iamanasha
    Member

    @iamanasha

    Sorry, I didn’t get back, I was MIA. Glad you got it resolved. :)

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.