Skip to:
Content
Pages
Categories
Search
Top
Bottom

Intergration. Will not let me logon using my wordpress login

  • I am getting this error at my site.

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Access denied for user ‘thechamp’@’localhost’ (using password: NO) in /home/thechamp/public_html/bbpress/bb-includes/db-mysqli.php on line 80

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in /home/thechamp/public_html/bbpress/bb-includes/db-mysqli.php on line 80

    Warning: Cannot modify header information – headers already sent by (output started at /home/thechamp/public_html/bbpress/bb-includes/db-mysqli.php:80) in /home/thechamp/public_html/bbpress/bb-includes/pluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at /home/thechamp/public_html/bbpress/bb-includes/db-mysqli.php:80) in /home/thechamp/public_html/bbpress/bb-includes/pluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at /home/thechamp/public_html/bbpress/bb-includes/db-mysqli.php:80) in /home/thechamp/public_html/bbpress/bb-includes/pluggable.php on line 164

    heres my config file

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘thechamp_wrdp1′); // The name of the database

    define(‘BBDB_USER’, ‘thechamp_risal’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘xxxxx’); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://idjam.com/bbpress/’;

    // What are you going to call me?

    $bb->name = ‘Support Forums’;

    // This must be set before you run the install script.

    $bb->admin_email = ‘*********’;

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = false;

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = 0;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ”; // Example: ’0123456789ab’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ‘wp_’; // WordPress table prefix. Example: ‘wp_’;

    $bb->wp_home = ‘http://idjam.com’; // WordPress – Options->General: Blog address (URL) // Example: ‘http://example.com’

    $bb->wp_siteurl = ‘http://idjam.com’; // WordPress – Options->General: WordPress address (URL) // Example: ‘http://example.com’

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );

    ?>

Viewing 25 replies - 1 through 25 (of 34 total)

  • chrishajer
    Participant

    @chrishajer

    Sounds like one of your four database settings is incorrect. Either the host, dbname, password or dbuser must be wrong. Is the database on another host? Are you sure the connection details are correct? Are you using the same database for your wordpress installation? You can check the settings in wp-config.php and see if they’re the same.

    Also, those are warnings, which are not good, but the connection was still made to the database.

    “Also, those are warnings, which are not good, but the connection was still made to the database. ” thats encouraging lol. Here is my wp-config file.

    Also both users have full access(thechamp_wrdp1 and thechamp_risal). I thought at first it was some type of permission issue so i created thechamp_risal to test.

    thanks again for the quick response

    <?php

    // ** MySQL settings ** //

    define(‘DB_NAME’, ‘thechamp_wrdp1′); // The name of the database

    define(‘DB_USER’, ‘thechamp_wrdp1′); // Your MySQL username

    define(‘DB_PASSWORD’, ‘xxxx’); // …and password

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    define(‘DB_CHARSET’, ‘utf8′);

    define(‘DB_COLLATE’, ”);

    // You can have multiple installations in one database if you give each a unique prefix

    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the

    // chosen language must be installed to wp-content/languages.

    // For example, install de.mo to wp-content/languages and set WPLANG to ‘de’

    // to enable German language support.

    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);

    require_once(ABSPATH.’wp-settings.php’);

    ?>

    Users in wrdp1

    thechamp_risal (Privileges: ALL PRIVILEGES)

    Connection Strings

    Perl $dbh = DBI->connect(“DBI:mysql:thechamp_wrdp1:localhost”,”thechamp_risal”,”<PASSWORD HERE>”);

    PHP $dbh=mysql_connect (“localhost”, “thechamp_risal”, “<PASSWORD HERE>”) or die (‘I cannot connect to the database because: ‘ . mysql_error());

    mysql_select_db (“thechamp_wrdp1″);

    thechamp_wrdp1 (Privileges: ALL PRIVILEGES)

    Connection Strings

    Perl $dbh = DBI->connect(“DBI:mysql:thechamp_wrdp1:localhost”,”thechamp_wrdp1″,”<PASSWORD HERE>”);

    PHP $dbh=mysql_connect (“localhost”, “thechamp_wrdp1″, “<PASSWORD HERE>”) or die (‘I cannot connect to the database because: ‘ . mysql_error());

    mysql_select_db (“thechamp_wrdp1″);

    here is MySql info also. Is there a way i could just run a standalone install and after the install intergrate them?

    I have the exact same problem.

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Access denied for user ‘watchstu’@’localhost’ (using password: NO) in /home/watchstu/public_html/forums/bb-includes/db-mysqli.php on line 80

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in /home/watchstu/public_html/forums/bb-includes/db-mysqli.php on line 80

    I noticed that in the error it says usingpassword: NO

    Well obviously it’s not going to connect to anything if it’s not using the password. Please fix this bug!


    chrishajer
    Participant

    @chrishajer

    Maybe this is a bug. I’ve seen that error reported a couple of times now…


    StefanJohansson
    Member

    @stefanjohansson

    I have this problem…

    I posted a thread about it before I read this discussion.

    Help is appreciated!

    I would like to use bbpress as soon as possible, I would appreciate it if some adventerous soul took a crack at it and made a few code edits.

    Thanks.

    After install bbpress 0.8.3 on windows XP localhost (WAMP5 1.7.3):

    if try access to Admin Panel i see warnings and nothing more…

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Access denied for user ‘ODBC’@’localhost’ (using password: NO) in C:wampwwwforumsbb-includesdb-mysqli.php on line 80

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in C:wampwwwforumsbb-includesdb-mysqli.php on line 80

    Warning: Cannot modify header information – headers already sent by (output started at C:wampwwwforumsbb-includesdb-mysqli.php:80) in C:wampwwwforumsbb-includespluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at C:wampwwwforumsbb-includesdb-mysqli.php:80) in C:wampwwwforumsbb-includespluggable.php on line 37

    Warning: Cannot modify header information – headers already sent by (output started at C:wampwwwforumsbb-includesdb-mysqli.php:80) in C:wampwwwforumsbb-includespluggable.php on line 164

    Forum some working but on top of page i see:

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Access denied for user ‘ODBC’@’localhost’ (using password: NO) in C:wampwwwforumsbb-includesdb-mysqli.php on line 80

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in C:wampwwwforumsbb-includesdb-mysqli.php on line 80

    From lasir’s config file, it looks like a common theme may be that the error message says:

    Access denied for user 'thechamp'@'localhost' (using password: NO)

    but the config file specifies a different user: thechamp_risal. (Can the others who are experiencing this problem please post the DB details of their setup as well?).

    This often indicates that the specified user doesn’t exist (or possibly doesn’t have access) in the specified database.

    Lasil, I’m not sure what this post is showing. Are you looking at users in the wrdp1 database or in thechamp_wrdp1?

    The other commonality here may be that all of you are using the mysqli extension. It could be that there’s a bug there that’s only now popping up since most people use the mysql extension.

    You can try overwriting /bb-includes/db-mysqli.php with /bb-includes/db.php (so that you have two copies of db.php) to see if that helps.

    That works, thanks.

    Miraploy,

    What works? Overwriting the files?

    This:

    You can try overwriting /bb-includes/db-mysqli.php with /bb-includes/db.php (so that you have two copies of db.php) to see if that helps.

    Miraploy, thanks!

    I’ve started a trac ticket to keep track of this bug.

    http://trac.bbpress.org/ticket/745


    chrishajer
    Participant

    @chrishajer

    Yep, I had same issue, and replacing /bb-includes/db-mysqli.php did the job


    honewatson
    Member

    @honewatson

    Ditto – replacing /bb-includes/db-mysqli.php did the job.

    Yeh! It work!!

    I have the same problem and overwriting db-mysqli.php with db.php didn’t help. Just for completeness, here’s the error messages I encounter:

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/<snip>/bbpress/bb-includes/db-mysqli.php on line 73

    I suspect bbPress of having hard coded a connection to localhost and thus configuring define('BBDB_HOST', '...') to be something else than localhost doesn’t really matter. I don’t have MySQL and Apache installed on the same physical server, so I have to access MySQL through a hostname and thus localhost won’t work.


    chrishajer
    Participant

    @chrishajer

    When using a socket, you need something like this:

    http://bbpress.org/forums/topic/cannot-select-db-error?replies=11#post-12434

    It’s OK to start a new topic as well. All these recent topics dredging up old problems that are sort of close make it hard to solve the latest problem, your problem. A lot of the earlier advice in this thread doesn’t apply to your specific problem.


    Sam Bauers
    Participant

    @sambauers

    > I suspect bbPress of having hard coded a connection to localhost and thus configuring define(‘BBDB_HOST’, ‘…’) to be something else than localhost doesn’t really matter.

    That’s simply not the case.


    livibetter
    Member

    @livibetter

    I don’t think you can connect to a remote MySQL server via unix socket. Please use TCP/IP.

    And don’t forget to grant the user for connecting from remote IP.


    livibetter
    Member

    @livibetter

    Yes, you surely can’t, cite from man mysql

    ·  --socket=path, -S path

    For connections to localhost, the Unix socket file to use, or, on
    Windows, the name of the named pipe to use.

    No remote IPC, if you can communicate via TCP/IP from remote, why use unix socket?

    The problem is; I’ve never explicitly told bbPress to connect via a local socket, and since I’m not a Unix expert, I didn’t really comprehend the error message. I now understand a bit more of what it says and that I should instruct bbPress to connect via TCP/IP instead. However, isn’t this something bbPress should have available as an option in the config.php file somehow? Or even just as an automatic switch it figures out based on whether BBDB_HOST is set (or is different from localhost) or not?


    chrishajer
    Participant

    @chrishajer

    It is fixed in the latest development version, I believe. There just hasn’t been a release that includes that functionality.

    http://bbpress.org/forums/topic/db-access-problem-in-the-first-installation-step?replies=26#post-12711


    Sam Bauers
    Participant

    @sambauers

    @chrishajer

    I’m not sure that’s the right advice. The latest development versions will definitely break integration as they are geared towards integration with the current WordPress trunk. There are lots of differences in password hashing and cookie storage.

    Revision [971] might be OK to use for this specific problem, but I can’t guarantee it. And it won’t fix socket connection under MySQLi.

Viewing 25 replies - 1 through 25 (of 34 total)

You must be logged in to reply to this topic.