Skip to:
Content
Pages
Categories
Search
Top
Bottom

Integrated with BuddyPress 1.5 and loving it! (via allmad.org)


  • Micheal Kennedy
    Member

    @intermike

    Our site allmad.org (a ranting community) is using the latest bbPress 2.0-RC3, and it’s working awesomely with BuddyPress 1.5! :) (When updating the plugin, don’t forget to visit the WP permalinks and resave them, else links to forums may not work.) I love how every time someone posts a reply or new topic, it shows up on their profile and on the Activity Stream – it’s so awesome! Keep up the good work guys!!!

Viewing 8 replies - 26 through 33 (of 33 total)

  • funnycat777
    Participant

    @funnycat777

    InterMike,

    Your site is awesome.

    Can I ask which theme template you are using to integrate buddypress and bbpress?


    Micheal Kennedy
    Member

    @intermike

    @funnycat777

    I’m using the Frisco theme (friscotheme.com); it’s pretty nice. Although it doesn’t suit my kind of site (a not-so-nice ranting social network), so I’m actually redesigning and it should be up in a few days, to something a little more “compact” and with less white space. But I do love the theme, though, and will probably use it on another project.


    Zhen
    Participant

    @milohuang

    Hello all, I got the exactly the same problem but I found a way that may be help.

    I was install the WP on my Mac using MAMP, then BP and BB and they both work and integrated well. Activity stream showed. And then, I moved the test to the web server, do the same thing, activity stream not working but I noticed the @ mention stuff did work. The only thing that is different from my local setting is, the visibility of WP. I set the web server one to “block from search engine” while the local one “visible”. And then, I turn on the “visibility” to open and it works!!!

    That’s it, simple and easy. It helps me but I am not sure whether it will be helpful for the rest of you!

    I cannot get the bbPress installation to generate activity feed items. I have tried every configuration that has been mentioned. I would like to understand what milohuang is saying tho…

    BP 1.5’s implementation of forums is very wacky. To get to the “Forums” settings page, where you can “install” group forums or sitewide forums you have to have the “group forums” button checked in the components page (this makes no sense). I don’t want group forums, just sitewide so why would I have to check the other button???!!!

    I tried unistalling group forums, unchecking the button and delting the “Forums” wp page and have a BP forum at /forums/ but new topics/replies still do not show in Activity. (yes show all is selected and site tracking is also enabled.)

    I just have to add that after looking everywhere in threads and forums and getting nowhere from the comments here I finally did what Zhen said.

    Setting Site Visibility to “Allow search engines to index this site.” will make Activity Stream work for bbPress posts!

    I tested this using WordPress 3.3.1, BuddyPress 1.5.3.1 and bbPress 2.0.2 so no nightlies involved.

    Thank you Zhen!

    Maybe you should add this info somewhere?

    -swex

    I’ve tried Setting Site Visibility to “Allow search engines to index this site.” on wpthemetrial.com, but I’m still not getting sitewide forum activity in my activity page.

    Can someone please tell me what I’m doing wrong!

    Thanks

    EB

    @Everton

    Did you follow the steps at the end of this thread?

    http://bbpress.org/forums/topic/how-do-i-set-up-bbpress-and-buddypress

    -swex

    yes I did, it didn’t work immediately but it’s working now so there must be some sort of lag.

Viewing 8 replies - 26 through 33 (of 33 total)

You must be logged in to reply to this topic.