Skip to:
Content
Pages
Categories
Search
Top
Bottom

Installation won’t launch.

  • Hey everyone,

    I need to pick your brains. I have uploaded bbPress in a folder called “forums” within “wp02″ (WordPress folder). I am using the same MySQL username and database info that WordPress uses since I want to integrate it. However, I’ve gone over config.php and I can’t seem to find an error. Can anyone offer assistance? Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘unrprus1_wp02′); // The name of the database

    define(‘BBDB_USER’, ‘unrprus1_John’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘xxxxxxxxx’); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://www.unrpredental.com/wp02/forums’;

    // What are you going to call me?

    $bb->name = ‘Message Board’;

    // This must be set before you run the install script.

    $bb->admin_email = ‘xxxx@unrpredental.com’;

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = false;

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = -7;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ‘b57b8370ac44′; // Example: ’0123456789ab’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ‘wp_’; // WordPress table prefix. Example: ‘wp_’;

    $bb->wp_home = ‘http://www.unrpredental.com’; // WordPress – Options->General: Blog address (URL) // Example: ‘http://example.com’

    $bb->wp_siteurl = ‘http://www.unrpredental.com/wp02′; // WordPress – Options->General: WordPress address (URL) // Example: ‘http://example.com’

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );

    ?>

    Okay, wow. It looks like I may have figured it out. All I did was set Permalinks to default within WordPress 2.3 and the installation came up. Sweet!

    Hey guys, I’m getting some new errors.. the config.php is still the same.

    This is what’s coming up:

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Access denied for user ‘unrprus1′@’localhost’ (using password: NO) in /home/unrprus1/public_html/wp02/forums/bb-includes/db-mysqli.php on line 80

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in /home/unrprus1/public_html/wp02/forums/bb-includes/db-mysqli.php on line 80

    Warning: Cannot modify header information – headers already sent by (output started at /home/unrprus1/public_html/wp02/forums/bb-includes/db-mysqli.php:80) in /home/unrprus1/public_html/wp02/forums/bb-admin/install.php on line 10

    Warning: Cannot modify header information – headers already sent by (output started at /home/unrprus1/public_html/wp02/forums/bb-includes/db-mysqli.php:80) in /home/unrprus1/public_html/wp02/forums/bb-includes/functions.php on line 1898

    P.S. There is no white space before the “<?php” tag.

    http://trac.bbpress.org/ticket/745

    This information helped me with the above situation.

    Make the changes per 745c.diff and you’ll be set.

    Thanks for a great program, Trent!

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.