Skip to:
Content
Pages
Categories
Search
Top
Bottom

Installation problem..please help fast


  • salman1485
    Member

    @salman1485

    Hi

    I owe the domain nofullstop.com and I started a domain test.nofullstop.com

    Then I set up a MySql database on the URL testforum.test.nofullstop.com

    After this I changed the config-sample.php file to config.php and entered the required information in that file.

    Now when I load http://test.nofullstop.com/bb-admin/install.php it shows a 404 error..??

    what did I miss??

    I upload the bbpress files to my root folder test.nofullstop.com/

    please help quick…please

    thank you

Viewing 9 replies - 1 through 9 (of 9 total)
  • umm..

    The rigth address is:

    http://test.nofullstop.com/bbpress/bb-admin/install.php

    :P

    Cheers


    chrishajer
    Participant

    @chrishajer

    1. Looks like this is the correct URL:

    http://test.nofullstop.com/bbpress/bb-admin/install.php

    2. Looks like the database connection details in config.php are incorrect:

    Cannot select DB.


    salman1485
    Member

    @salman1485

    I am not sure what is wrong with my config.php file..

    this is a test forum which i am not finalising so i created a new database with new password and new user and updated the config.php file with the details…please tell me what is the problem..am copying the file here (pwd, akismet key, email have been removed)

    ______________________________________________

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘testforum’); // The name of the database

    define(‘BBDB_USER’, ‘testforum’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ”); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_'; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://test.nofullstop.com/';

    // What are you going to call me?

    $bb->name = ‘test forum';

    // This must be set before you run the install script.

    $bb->admin_email = ‘something@gmail.com';

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = slugs;

    // The number of topics that show on each page.

    $bb->page_topics = 15;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 1;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = 0;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ‘en’);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ”; // Example: ‘0123456789ab’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ”; // WordPress table prefix. Example: ‘wp_';

    $bb->wp_home = ”; // WordPress – Options->General: Blog address (URL) // Example: ‘http://example.com’

    $bb->wp_siteurl = ”; // WordPress – Options->General: WordPress address (URL) // Example: ‘http://example.com’

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );

    ?>

    ______________________________________________

    please help me ..


    chrishajer
    Participant

    @chrishajer

    Posting an edited config will not help in this case. The error you have is because it cannot connect to the database, and the only way for someone to verify that would be to see your database connection details. Are you certain the database name, username, password and host are all absolutely correct? Do you use that same database elsewhere (like for WordPress maybe) where you can verify things are entered exactly the same in both places?


    salman1485
    Member

    @salman1485

    i use different database for my wordpress blogs and i created new database for my test forum

    database name: testforum

    user: testforum

    password is also correct

    I doubt what I need to enter in host..currently it is localhost and i am using dreamhost to host my account… but i am sure i do not need to enter that in place of localhost..!! :)

    so what could be the problem?

    and in that BBLANG i have written en even though i dont have any MO file..

    confused …please help me


    chrishajer
    Participant

    @chrishajer

    It is most certainly a problem with the details you have entered for the database. One of the four items is incorrect: that is precisely what the Cannot select DB error is telling you.

    I can help you off list of you would like to contact me (check my profile for a website where you will find contact information.) I will need access to the config.php and your Dreamhost control panel to see the database details.


    salman1485
    Member

    @salman1485

    problem solved.. :)

    instead of localhost i had to enter the other thing which dreamhost told me …

    but now another problem

    the forum is working fine http://test.nofullstop.com/bbpress/

    but the slugs arnt??

    what went wrong now??


    _ck_
    Participant

    @_ck_

    Before I got to the bottom I almost knew right off it was dreamhost and a localhost issue.

    Slugs aren’t working because they don’t do multiviews.

    You’ll have to place a real htaccess file into the directory with rewrite rules.

    http://bbpress.org/documentation/faq/#pretty-permalinks


    chrishajer
    Participant

    @chrishajer

    Or, just turn off permalinks in your config.php:

    $bb->mod_rewrite = false;

    At least at that point, things would work for you.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.