Skip to:
Content
Pages
Categories
Search
Top
Bottom

I need help with integration


  • thomasfals
    Member

    @thomasfals

    I have installed wordpress 3.0.1 and bbpress 1.0 inside the wordpress folder. They share the same database.

    I have added the following lines to the wp-config before the mysql strings:

    define( 'COOKIEHASH', 'd1f7eec6931cdc9bcabcda54b479078e' );
    define( 'SITECOOKIEPATH', '/' );
    define( 'COOKIEPATH', '/' );

    And these longer down:

    define('AUTH_KEY',         'Lut=fA6L$vvH;jt+<3$.Uu;-x$SScbTh}>I0$G7d8<code></code>%H]/%F<eFY

    )NM6tMw_2ao’);

    define(‘SECURE_AUTH_KEY’, ‘Q0e8f|n[NN-7-}w-:9-}s-Yt5UjbM-_E>]88/j|cgG d++%q7m%kx+Y*|Vn&c{)8′);

    define(‘LOGGED_IN_KEY’, ‘YhYj/aHOg>(D|2C({PUGC {QCh?<^y-8-[EGp-]{IYKz{o.XtwLLp3z|i5>x&&’);

    define(‘NONCE_KEY’, ‘-t%dnVN}E?2lFeXbl!Kqaaa@o3|u8|%I5cUMlZ:Kwj$dX,*V(ilrFokuF]w9$h??’);

    define(‘AUTH_SALT’, ‘^B-eC)mvb?-Swa!0V[W,; -FwUNW^-;Rqc-+GrHmlw64Qaa7w:.fUceuEqv;Na(/');

    define('SECURE_AUTH_SALT', 'Hyv|rxFT^1it2pfXQ|S-KAwIL$Q[D^+-Pv=9XAW.V}r}H&cXZ@%=F*ds8Em:Q`8M');

    define('LOGGED_IN_SALT', 'b#A_A2wBKz-):+EVBE$ZpOZ]k!fEFYh(K@ZJP+y W/casO0aP8nx|b/)O*p~M_OK’);

    define(‘NONCE_SALT’, ‘~Il&]x.h,Pl0g2ac{jSZ]XEAU –kn{Hw;@&B`dZ[#/uaNyQ+z9K)YWfWhmX +

    M7');

    These have been added to the bb-config.php before the mysql strings:

    define( 'SITECOOKIEPATH', '/' );
    define( 'COOKIEPATH', '/' );

    And these longer down:

    define('BB_AUTH_KEY',         'Lut=fA6L$vvH;jt+<3$.Uu;-x$SScbTh}>I0$G7d8<code></code>%H]/%F<eFY

    )NM6tMw_2ao');

    define('BB_SECURE_AUTH_KEY', 'Q0e8f|n[NN-7-}w-:9-}s-Yt5UjbM-_E>]88/j|cgG d++%q7m%kx+Y*|Vn&c{)8');

    define('BB_LOGGED_IN_KEY', 'YhYj/aHOg>(D|2C({PUGC {QCh?<^y-8-[EGp-]{IYKz{o.XtwLLp3z|i5>x&&');

    define('BB_NONCE_KEY', '-t%dnVN}E?2lFeXbl!Kqaaa@o3|u8|%I5cUMlZ:Kwj$dX,*V(ilrFokuF]w9$h??');

    define('BB_AUTH_SALT', '^B-eC)mvb?-Swa!0V[W,; -FwUNW^-;Rqc-+GrHmlw64Qaa7w:.fUceuEqv;Na(/');

    define('BB_SECURE_AUTH_SALT', 'Hyv|rxFT^1it2pfXQ|S-KAwIL$Q[D^+-Pv=9XAW.V}r}H&cXZ@%=F*ds8Em:Q`8M');

    define('BB_LOGGED_IN_SALT', 'b#A_A2wBKz-):+EVBE$ZpOZ]k!fEFYh(K@ZJP+y W/casO0aP8nx|b/)O*p~M_OK');

    define('BB_NONCE_SALT', '~Il&]x.h,Pl0g2ac{jSZ]XEAU --kn{Hw;@&B`dZ[#/uaNyQ+z9K)YWfWhmX +M7');

    In the wordpress integration plugin I checked that the table prefix is set to wp_. Also the "auth", "secure auth" and "logged in" cookies are locked as they have been matched.

    The wordpress url is set correct and the bbpress integration plugin has been added and the bbpress url is set. I have deleted all cookies, but regardless I am not logged into bbpress when I log into wordpress.

    I have mapped the users as key, moderator, member, member, member. Any ideas what I am doing wrong?

Viewing 6 replies - 1 through 6 (of 6 total)

  • thomasfals
    Member

    @thomasfals

    Seems like I inserted a code tag at the wrong place in the above post. However, the keys are correct on both sides.


    kevinjohngallagher
    Member

    @kevinjohngallagher

    I’ve never had to define the “COOKIEHASH” before.

    The wordpress integration plugin is quite useless, its really only there to give you the cookiepath as “/”.

    9/10 I find the solution can be found by going through this step by step guide:

    http://wpbbpthemes.org/integration/


    thomasfals
    Member

    @thomasfals

    Hi Kevin

    Thanks for the tip. However, I have already followed the guide once and I just did it again to double check.

    All keys match in both config files. The bb press once has BB_ added in front of the key names. The cookie paths has been set, users mapped, and even the wp-load.php has been set. Keys are correct as they appear locked in the “wordpress integration” section of bbpress – also the table_prefix is set to wp_ as it should. Basically I think everything has been set up as it should.

    I am testing this using mamp pro and the bbpress folder is inside the wordpress folder. I am beginning to think it has something to do with my setup. I have been trying to figure it out for days now.


    thomasfals
    Member

    @thomasfals

    Let me just add that it is the shared login that does not work. The deep integration is working and I am using the wordpress menu inside the bbpress theme without any problems.


    thomasfals
    Member

    @thomasfals

    No other suggestions?


    thomasfals
    Member

    @thomasfals

    Could it have anything to do with my wordpress install being at http://larm:8888 and the forum at http://forum.larm:8888 ?

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.