Skip to:
Content
Pages
Categories
Search
Top
Bottom

Huh. I seem to have mucked this up.


  • Racket Magazine
    Member

    @racket-magazine

    I’m trying to add forums to our website, and was pretty stoked when I finally realized that I was one of the 1% who had to change the localhost tag and got a forum to appear magically where it was supposed to be. But! Now half the links don’t work. I seem to be able to create a post, but when I click the button to post it, it sends me to a lovely 404 error, yet the dang thing is posted. I can access the Admin section, but none of the actual forums or any of the profile links work. Did I muck this up or is there something more diabolical at work? Here’s the link to it:

    http://racketmag.com/forums/

Viewing 7 replies - 1 through 7 (of 7 total)

  • _ck_
    Participant

    @_ck_

    You’re almost there. You need to either turn on multiviews or rewrite rules in your htaccess file if you want to use slugs. See #2 or #3 here:

    http://bbpress.org/documentation/faq/

    I recommend #3 even though it’s a few more steps.

    Some servers don’t even support multiviews so #3 is a must.


    Racket Magazine
    Member

    @racket-magazine

    OK, now, bear with me here, as my coding experience is pretty much based on what I learned 8 years ago in some highschool internet class. I am attempting to create this .htaccess file, and when I went to create it, a prompt came up alerting me to the fact that a file starting with a . is reserved for system files. Do I save it with the .? Also, is it a .php file?


    chrishajer
    Participant

    @chrishajer

    No, it is JUST .htaccess – the . indicates it’s a hidden file, and there is no file extension. The Apache webserver looks for that file for direction on some hosts.


    Racket Magazine
    Member

    @racket-magazine

    I use yahoo as my server, and it won’t let me create a file starting with a period. I tried naming it without the ., and then renaming it, but it wouldn’t let me. What’s the next step?


    chrishajer
    Participant

    @chrishajer

    Don’t use permalinks. Find the mod_rewrite line (line 27 in mine) in your config.php and change it to look like this:

    $bb->mod_rewrite = false;

    That will turn off the permalinks and all the links will work again.


    _ck_
    Participant

    @_ck_

    Yahoo has free hosting that has mysql and php support? Wild.

    But if you are paying for that, you might want to find a real host that allows basic things like .htaccess files – which would be virtually any other host.

    A quick google shows this is a common complaint about yahoo.


    Racket Magazine
    Member

    @racket-magazine

    Eek. Well, I’ll keep it on Yahoo for a little bit longer while I finish my attempts at utilizing WordPress to drive the new site design. Then I’ll see about launching it on another server. It’s bizarre to me that yahoo can’t do that, especially seeing that wordpress is an option on the backend server. I appreciate all the help!

    *Wait, I didn’t catch the setting the dang line of code to false. It looks like we’re rolling. Just in time for me to be exhausted. Thanks for everything, guys.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.