Skip to:
Content
Pages
Categories
Search
Top
Bottom

https vs http for bbPress URL

  • I have a navigation button on my website linking to a bbPress forum, which works fine in IE, but won’t work in Firefox. Apparently it is a security issue.

    My host Support has advised that changing the bbPress URL from https protocol to http will resolve the issue, but I’m wondering why https is the default protocol when you install bbPress?

    I am aware that https ensures security for exchange of credit card info etc, but in the case of my forum, there won’t be any such security issues as far as I know. The forum is just a place for students to post research proposals and the like, and feedback to each other, and for their lecturers to do likewise.

    Does anyone know, please, if there is any reason I should NOT change the forum URL from https to http?

Viewing 10 replies - 1 through 10 (of 10 total)
  • just use http://.


    chrishajer
    Participant

    @chrishajer

    https is *not* the default protocol when installing bbPress. What gives you the idea that it is? Was a field pre-filled with a https:// value? Did you navigate to the installer from an https page? Or is the link to bbPress coming from an https page?

    Just change it to http:// unless you have an SSL certificate and require the security.

    Oops – edited after _ck_’s message below.


    _ck_
    Participant

    @_ck_

    I suspect the problem is they have a link to bbPress’s http url from a page that is already https. So the browser gives a warning that the visitor is traveling outside of https.

    You could install bbpress as normal to the http url but link from that page as https and just rewrite the url.

    Offhand, if you really have a SSL cert though, the next version of bbPress, like WP 2.6 will be able to handle https logins for what that’s worth (even the current version could be forced to with with SSL but it’s overkill).


    chrishajer
    Participant

    @chrishajer

    _ck_ I think you’re right.

    Here is the https page:

    https://ashb.proofreadercentral.com/bbpress/

    And if you click the button to go back to the main site, you get the warning that you are leaving a secure site for a non-secure one.

    But it is also available at:

    http://ashb.proofreadercentral.com/bbpress/

    and if you click the button there, you don’t get the browser dialog with the security warning.

    Just use http:// everywhere and it will be fine (website and forum.)

    Thanks, guys. Have done as recommended and changed to http://

    This is weird though: Chris’s link to the https:// site, which I’ve now replaced with an http:// one, still opens! How could this be, that it’s still floating around out there when I’ve replaced it?

    I’ve cleared my cache in case the link was bringing up the cached site, but the link still works. What am I not getting here?


    chrishajer
    Participant

    @chrishajer

    You might have https hard coded in something. Or, if you start with an https URL, your links are always https also. Search the source of your files for https and if it’s not there, then just be sure to use http to link to your website and forum. Users won’t normally use https unless they click on a link from somewhere.

    If you’re bothered by it, you could always create a rewrite rule in .htaccess to direct any https traffic to http.


    chrishajer
    Participant

    @chrishajer

    BTW – the site is the same, no matter which URL you use (http or https) – it’s just secured with SSL over https. If there is aa SSL certificate for the domain, then the site will still work over https. If there isn’t a certificate, the user will get a security warning about a missing or mismatched certificate.

    Just an addendum that might prove useful to others.

    I changed the index page to http, which I thought was all that had to be done. However, after doing so, I was getting a mixture of https and http pages – the home page of the forum was http, but any page inside (eg: forum headings and posts) were coming up with the https prefix.

    There was a simple solution: change the URL in the General Settings section of the Admin area! I guess it was assumed I’d done this (never underrate the capacity of a tech uninitiate to not do the right thing!).

    The forum uses only HTTP now, and there’s a bonus that comes with this (which is why I thought it worth writing this post) – the pages load MUCH FASTER!


    chrishajer
    Participant

    @chrishajer

    Congrats.

    i am not sure if anybody came with this problem:

    when i installed bbpress using https:

    i could not login bb-admin

    and when i tried to login

    it brings me back to the top page.

    instead i use http to install bbpress again,

    all works OK

    anyone know what’s the problem?

    thanks

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.