Skip to:
Content
Pages
Categories
Search
Top
Bottom

How to get bbPress to work on a local WAMP installation


  • april
    Participant

    @aprilmaynard

    I’ve installed bbPress on a local installation, under port 8080 to avoid a conflict with another program using port 80. It appears to work just fine from the WordPress Dashboard, but I can’t do anything in the front end – I keep getting ERROR: Are you sure you wanted to do that?

    I’ve spent the last hour on Google, reddit, this forum, various blogs… nothing seems to help.

    Can someone explain how to fix this, please? I posted the same question last week and got zero response.

    This installation is staying on a local machine, so it isn’t as though all my problems will soon be solved. I’m never uploading to a normal hosting server.

    Any help would be appreciated.

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)

  • april
    Participant

    @aprilmaynard

    I don’t get it. Is there no answer to this question or what?

    Why do other topics appear to be posted after mine and still receive responses?

    This is getting incredibly frustrating.


    april
    Participant

    @aprilmaynard

    Bump.


    David_PR
    Participant

    @david_pr

    I had the same problem with a trial WP site I have running locally on my Mac, using MAMP.
    The problem disappeared after I did…

    [1]
    Dashboard / Settings / Permalink = Post Name.
    Dashboard / Settings / General: Anyone Can Register = Y; New User Default Role = Subscriber.
    Dashboard / Settings / Forums: Default User Role = Participant; leave other settings at default.

    [1]
    Dashboard / Settings / General Settings
    Two fields to edit, called “WordPress Address (URL); Site Address (URL).
    http://localhost:8888/wordpress ORIGINAL…PROBLEM
    http://localhost:80/wordpress REVISED… STILL PROBLEM
    http://localhost/wordpress REVISED… NO PROBLEM!

    [3]
    At the MAMP control panel click on Preferences; click on button “Set Apache & MySQL ports to 80, 3306. Log in again to WP.

    – – – – – – – – – – – – – – – – – – – – – – – – –
    Worked for me!

    David

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.