Skip to:
Content
Pages
Categories
Search
Top
Bottom

Help! I renamed my bbpress file directory name…


  • deltaqo
    Member

    @deltaqo

    ok — I’m a newbie to bbpress, and a relative newbie to wordpress, so please bear with me.

    I have wordpress installed in my site’s root directory. I installed bbpress into root/bbpress. I made all the needed settings to changes to call the wp headers from my bb-config file, and vice versa.

    Then, I made a newbie mistake of trying to rename my bbpress folder to root/forums, and also changed the setting in my bbpress admin > settings of my bbpress directory to “root/forums.” (thinking this would somehow magically just work) Now, when I try to access my bbpress admin page, I simply get redirected to my wordpress homepage. It seems that the header information is screwed up now, I suspect it has something to do with the filenames and absolute paths, but I have no idea how to fix it or to begin diagnosing it.

    Please help!

Viewing 15 replies - 1 through 15 (of 15 total)

  • _ck_
    Participant

    @_ck_

    Try editing your bb-config.php file and put in a line like this:

    $bb->uri = 'http://your-domain-name.com/forum-path/';

    It may also require a forced change of your cookiepath if you can’t login.


    deltaqo
    Member

    @deltaqo

    thanks for the reply _ck_.

    i tried your suggestion, and i’m still being redirected to my blog homepage when i try to access mysite/forum/bb-admin.

    i’m wondering whether my BB_PATH settings got messed up when i switched the folder name manually?

    also, how would i do a forced change of my cookiepath (as you suggest above)?


    chrishajer
    Participant

    @chrishajer

    I just tried this same thing to see if I could recreate the problem. I renamed my bbpress folder, then navigated to the new URL. The forum came up. I tried to log in; I was redirected to the OLD url and got a WordPress 404 page since there is no page there.

    Then, I added the line that _ck_ recommended in bb-config.php:

    $bb->uri = ‘http://your-domain-name.com/forum-path/’;

    And I navigated to the new URL again. The forum came up. Then I tried to log in, and I logged in fine. In the admin, in the settings tab, the new URL is there (the one I entered in the bb-config.php, per _ck_’s suggestion.)

    If this was not your experience, maybe you have a problem with permalinks or mod_rewrite rules. Try turning permalinks off and navigating to the forum again.

    p.s. I didn’t do anything with the cookies, and I do not have an integrated installation. Just a WordPress site with a forum in a sub-directory.


    dpeeples
    Member

    @dpeeples

    i followed your instructions as well as i could but got a messed up page after inserting the

    $bb->uri = ‘http://your-domain-name.com/forum-path/’

    portion in the config code.

    Where exactly should it go?

    thanks much for the help.


    springnet
    Member

    @springnet

    I did exactly the same thing and pffft. So I had to rename it back from forum to bbpress on http://spring.net/bbpress (for now!) until I can get it to work at http://spring.net/bb/ (hopefully soon)


    Erica S
    Member

    @estrahon

    If there’s nothing on your forum yet, then just do a clean install. You have to rename the folder before you install it.


    chrishajer
    Participant

    @chrishajer

    dpeeples – I don’t think it matters. I put it right after the secret key line and it worked fine.


    _ck_
    Participant

    @_ck_

    I should point out that such changes in bb-config.php must be inserted ABOVE the line that says

    /* Stop editing */ and not below it.

    Also, you should go immediately into your config and change the path after that.

    In fact you should probably change the path in the admin section FIRST and then rename the folder after it’s saved. bbPress will be disabled until you rename the folder but should spring back to life afterwards.

    The menu I mean is under:

    settings -> general

    or http://your-website-name.com/your-forum-path/bb-admin/options-general.php

    bbPress address (URL):


    sonza
    Member

    @sonza

    Hmm, I just installed bbPress and wanted to rename my folder from ‘forum’ to ‘forums’.

    I was searched for the correct way to do this and apparently, all i did was to change the directory I wanted bbPress to work on in the admin>settings section, then rename the folder.

    maybe seeing as this topic is 3 weeks old, there may have been changes to the system regarding this.


    chrishajer
    Participant

    @chrishajer

    I don’t think were any changes. The original poster had problems I don’t think anyone was able to recreate. I had no trouble with it; same as your experience. Maybe their configuration was different in some way.

    I changed my directory as according to sonza’s instructions and it worked…but I have a problem.

    I had bbPress synchronization set up, but it’s not quite working anymore. It creates the new topic whenever I make a new post, but when I click on it in the forum, I get redirected to a “Nothing found…” page.

    Other than uninstalling and reinstalling everything, is there anything I can do to fix this?

    Thanks, Adam

    nvm I’m cool now, all I had to do was disable then reenable permalinks :)

    hi,i think that i have solved it!

    i have a hostmonster.com account,so i change one domains folder to another domains folder.like xxx.com/bbs====>yyy.com and then i take some hours to test some solutions and at last i make my webistes work well. hehe.

    my solution is that: change 2 data of database.

    look below:

    [bb_forums]====> [1 xxx.com/bbs]


    >[1 yyy.com]

    [bb_meta]====> [3 bb_option 0 uri http://xxx.com/bbs


    > [3 bb_option 0 uri http://yyy.com

    if oke,please feedback a comment!


    Josh Stauffer
    Member

    @joshstauffer

    I know this topic was started 1 year ago but I thought I’d share my success story.

    To start, I just want to note that I have the Permalink type set to Numeric.

    First, in the Admin section, I went to Settings > General and changed the bbPress address (URL) from http://www.mysite.com/bbpress/ to http://www.mysite.com/forums/

    Next, I renamed the directory /bbpress/ to /forums/ in my hosting account.

    Finally, I opened up the .htaccess file in the root of bbPress and did a find a replace. I replaced “bbpress” with “forums” without the quotes. Saved it and reloaded the site.

    Worked like a charm (for me)!


    moneyonlinetalk
    Participant

    @moneyonlinetalk

    No matter what i tried i can’t seems to get this works on my websites, i have installed it and name it discussion on my Website here and also am doing everything i can to add it on one of my partner authority site University News i hope someone out there help me out.

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.