Skip to:
Content
Pages
Categories
Search
Top
Bottom

Headers already sent when logging in

  • If you use the main log-in form at the top of my forum, everything works fine. But, if you’re not logged in and you click on add new next to topic, it asks you to log in and when you do you get this error:

    Warning: parse_url(http://#postform) [function.parse-url]: Unable to parse URL in /home/indiesho/public_html/forum/bb-includes/pluggable.php on line 272

    Warning: Cannot modify header information – headers already sent by (output started at /home/indiesho/public_html/forum/bb-includes/pluggable.php:272) in /home/indiesho/public_html/forum/bb-includes/pluggable.php on line 228

Viewing 4 replies - 1 through 4 (of 4 total)
  • I didn’t resolve this so I’m going to leave it as not resolved, but, I did make some changes so I no longer need this fixed. I took out the Add New next to topic and replaced it with “You must log in to post”. Which only shows up if the person is not logged in… it works great this way.

    wilcosky – I take it you’re seeing this with a modified theme. You may have put the wrong php in whatever template you modded. What did you take out and from what file?


    _ck_
    Participant

    @_ck_

    Headers already sent is a useless error in itself, it’s always the result of another error (unless the very rare case someone meant to send a custom header of some kind).

    In this case at least you posted the real error:

    Warning: parse_url(http://#postform) [function.parse-url]

    Any chance you are testing this on a localhost or something like that?

    Kind of a strange error that it’s getting a bad url like like, there’s no domain name at all.


    0x000BLAh
    Member

    @0x000blah

    I had such error when wrong plugins were enabled. Try to move all plugins from plugins dir, go to forum, then move them back, return to the forum and try to activate em one by one (of course u’ll have to check forum every time u activate new one)…

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.