Skip to:
Content
Pages
Categories
Search
Top
Bottom

Getting errors in my log


  • kvr28
    Participant

    @kvr28

    anytime someone posts a reply, I see something like this in my error log, I ran the repair tool and still see them, any suggestions?

    LONG QUERY: SELECT COUNT(ID) FROM rufus_posts WHERE post_parent IN ( 31303,31259,31194,31042,31039,31038,30961,30951,30950,30867,30620,30586,30581,30476,30459,30425,30241,30230,10577,10575,10513,10464,10410,10408,10404,10372,10350,10317,10301,10268,10254,10247,10246,10225,10218,10212,10203,10202,10165,10146,10075,10064,10059,10045,10044,10035,10026,9990,9988,9978,9968,9956,9954,9940,9939,9934,9926,9924,9920,9911,9900,9892,9887,9876,9871,9870,9858,9849,9848,9838,9837,9836,9827,9824,9799,9777,9755,9742,9717,9638,9621,9617,9609,9601,9590,9561,9553,9538,9534,9521,9496,9483,9482,9481,9480,9476,9464,9462,9461,9459,9449,9448,9437,9433,9432,9430,9403,9399,9392,9381,9368,9363,9357,9353,9348,9346,9328,9327,9312,9307,9306,9301,9279,9274,9263,9231,9230,9227,9225,9223,9222,9218,9212,9205,9204,9198,9197,9194,9190,9182,9181,9176,9170,9163,9156,9149,9144,9139,9135,9133,9114,9103,9102,9101,9078,9068,9062,9057,9047,9037,9036,9029,9028,9024,9011,9008,8995,8979,8973,8970,8964,8944,8926,8922,8918,8909,8904,8879,8869,8867,8861,8847,8837,8827,8814,8812,8811,8796,8786,8775,8769,8766,8764,8758,8744,8733,8730,8720,8719,8707,8695,8671,8670,8640,8635,8611,8607,8593,8590,8577,8573,8563,8550,8547,8546,8542,8541,8540,8539,8538,8534,8532,8499,8465,8461,8457,8448,8419,8361,8319,8310,8307,8276,8268,8263,8253,8237,8206,8192,8165,8109,8108,8104,8057,8049,8039,8025,8004,7992,7978,7969,7953,7949,7948,7943,7897,7894,7873,7869,7866,7728,7726,7691,7673,7622,7579,7567,7549,7547,7517,7469,7460,7454,7449,7447,7379,7370,7365,7348,7304,7280,7277,7261,7250,7243,7219,7216,7199,7178,7165,7162,7103,7095,7091,7090,7084,7039,7036,7027,7026,6981,6960,6944,6936,6927,6915,6898,6872,6866,6851,6835,6828,6770,6761,6760,6759,6748,6746,6745,6699,6686,6672,6643,6595,6577,6562,6525,6514,6509,6486,6482,6450,6449,6448,6442,6428,6412,6382,6373,6364,6352,6351,6322,6317,6307,6306,6285,6268,6257,6237,6227,6194,6141,6138,6133,6125,6090,6070,6050,6026,6021,6013,6010,5998,5980,5965,5948,5923,5908,5903,5881 ) AND post_status = ‘publish’ AND post_type = ‘reply’;, referer: http://thehomesteadingboards.com/forums/topic/a-2-liter-bottle-chicken-waterer/

Viewing 12 replies - 1 through 12 (of 12 total)

  • kvr28
    Participant

    @kvr28

    just ran repair and optimize on the rufus_posts table through phpmyadmin didn’t fix it


    kvr28
    Participant

    @kvr28

    I did some more testing, disabled all plugins except bbpress, still getting the error, but when I made a thread in the announcement and suggestions sub under support, I got no error, when I made one under the compost bin, I did

    http://thehomesteadingboards.com/forums/

    any ideas?


    kvr28
    Participant

    @kvr28

    just noticed, I’m getting the error when running the forum tools

    LONG QUERY: SELECT COUNT(ID) FROM rufus_posts WHERE post_parent IN ( 31303,31259,31194,31042,31039,31038,30961,30951,30950,30867,30620,30586,30581,30476,30459,30425,30241,30230,10577,10575,10513,10464,10410,10408,10404,10372,10350,10317,10301,10268,10254,10247,10246,10225,10218,10212,10203,10202,10165,10146,10075,10064,10059,10045,10044,10035,10026,9990,9988,9978,9968,9956,9954,9940,9939,9934,9926,9924,9920,9911,9900,9892,9887,9876,9871,9870,9858,9849,9848,9838,9837,9836,9827,9824,9799,9777,9755,9742,9717,9638,9621,9617,9609,9601,9590,9561,9553,9538,9534,9521,9496,9483,9482,9481,9480,9476,9464,9462,9461,9459,9449,9448,9437,9433,9432,9430,9403,9399,9392,9381,9368,9363,9357,9353,9348,9346,9328,9327,9312,9307,9306,9301,9279,9274,9263,9231,9230,9227,9225,9223,9222,9218,9212,9205,9204,9198,9197,9194,9190,9182,9181,9176,9170,9163,9156,9149,9144,9139,9135,9133,9114,9103,9102,9101,9078,9068,9062,9057,9047,9037,9036,9029,9028,9024,9011,9008,8995,8979,8973,8970,8964,8944,8926,8922,8918,8909,8904,8879,8869,8867,8861,8847,8837,8827,8814,8812,8811,8796,8786,8775,8769,8766,8764,8758,8744,8733,8730,8720,8719,8707,8695,8671,8670,8640,8635,8611,8607,8593,8590,8577,8573,8563,8550,8547,8546,8542,8541,8540,8539,8538,8534,8532,8499,8465,8461,8457,8448,8419,8361,8319,8310,8307,8276,8268,8263,8253,8237,8206,8192,8165,8109,8108,8104,8057,8049,8039,8025,8004,7992,7978,7969,7953,7949,7948,7943,7897,7894,7873,7869,7866,7728,7726,7691,7673,7622,7579,7567,7549,7547,7517,7469,7460,7454,7449,7447,7379,7370,7365,7348,7304,7280,7277,7261,7250,7243,7219,7216,7199,7178,7165,7162,7103,7095,7091,7090,7084,7039,7036,7027,7026,6981,6960,6944,6936,6927,6915,6898,6872,6866,6851,6835,6828,6770,6761,6760,6759,6748,6746,6745,6699,6686,6672,6643,6595,6577,6562,6525,6514,6509,6486,6482,6450,6449,6448,6442,6428,6412,6382,6373,6364,6352,6351,6322,6317,6307,6306,6285,6268,6257,6237,6227,6194,6141,6138,6133,6125,6090,6070,6050,6026,6021,6013,6010,5998,5980,5965,5948,5923,5908,5903,5881 ) AND post_status = ‘publish’ AND post_type = ‘reply’;, referer:


    kvr28
    Participant

    @kvr28

    did some more testing on my staging site, deleted everything except for bbpress, deleted bbpress, reinstalled it, switched to twenty twelve theme and repaired and optimized all the database tables, ran the forum tools and still having this issue. I even stripped all the forum categories and re ran the tools to see if that stopped it, nope. So next I tried removing the forums slug, re ran the tools and tried it, nada, any suggestions from here?

    [Wed Mar 26 13:41:38 2014] [error] [client ##.###.###.##] LONG QUERY: SELECT COUNT(ID) FROM rufus_posts WHERE post_parent IN ( 31248,31247,31229,31128,30999,30794,30793,30781,30780,30779,30777,30693,30681,30680,30679,30676,30668,10648,10645,10641,10635,10630,10624,10616,10606,10602,10596,10594,10593,10591,10590,10586,10583,10559,10557,10527,10526,10525,10524,10523,10515,10507,10506,10505,10499,10491,10489,10486,10478,10477,10467,10466,10454,10430,10429,10422,10415,10402,10381,10380,10374,10366,10365,10354,10345,10333,10322,10320,10313,10302,10293,10278,10277,10251,10234,10229,10205,10201,10200,10194,10184,10182,10169,10159,10156,10148,10147,10139,10129,10118,10113,10091,10084,10077,10076,10070,10067,10066,10061,10058,10051,10050,10047,10038,10025,10023,10015,10014,10010,10009,10008,10002,9997,9996,9995,9982,9980,9979,9977,9971,9962,9941,9938,9935,9932,9931,9930,9915,9914,9913,9909,9908,9899,9890,9889,9888,9885,9884,9869,9864,9859,9856,9852,9847,9843,9842,9834,9830,9829,9818,9815,9797,9771,9768,9752,9736,9726,9725,9724,9709,9708,9707,9706,9705,9700,9696,9690,9673,9663,9662,9658,9655,9639,9619,9614,9611,9605,9584,9577,9566,9558,9557,9554,9548,9546,9540,9533,9532,9527,9525,9517,9515,9506,9499,9488,9478,9471,9467,9466,9454,9440,9436,9434,9431,9426,9425,9424,9421,9416,9398,9394,9393,9388,9386,9385,9365,9364,9356,9352,9343,9337,9330,9317,9313,9310,9309,9305,9303,9296,9294,9293,9291,9276,9275,9262,9261,9260,9240,9239,9237,9233,9214,9213,9203,9192,9188,9178,9177,9169,9168,9162,9160,9158,9152,9145,9142,9137,9136,9134,9131,9130,9125,9115,9111,9108,9105,9100,9089,9086,9084,9083,9079,9075,9065,9059,9058,9048,9043,9018,9013,9012,9003,8998,8992,8985,8969,8959,8946,8945,8940,8938,8931,8930,8929,8928,8927,8925,8914,8911,8903,8902,8899,8896,8893,8889,8887,8880,8870,8868,8865,8862,8854,8848,8840,8829,8805,8804,8799,8797,8795,8794,8792,8780,8777,8774,8770,8768,8765,8759,8756,8754,8752,8747,8742,8732,8715,8709,8705,8701,8694,8691,8684,8683,8679,8674,8673,8662,8656,8654,8636,8613,8609,8598,8597,8581,8569,8566,8560,8559,8553,8535,8512,8510,8507,8503,8502,8497,8466,8458,8439,8431,8428,8418,8417,8412,8410,8403,8375,8369,8368,8366,8359,8331,8330,8327,8305,8291,8290,8269,8267,8266,8261,8258,8249,8246,8244,8236,8233,8222,8217,8215,8207,8204,8195,8173,8171,8168,8162,8147,8146,8144,8140,8138,8136,8135,8133,8132,8131,8125,8117,8115,8111,8103,8101,8099,8088,8078,8077,8074,8072,8070,8069,8067,8060,8059,8058,8047,8045,8044,8029,8019,8011,8010,8009,8001,7982,7972,7957,7954,7942,7935,7931,7930,7929,7922,7912,7911,7902,7888,7885,7864,7853,7852,7846,7840,7839,7829,7827,7810,7808,7797,7782,7738,7727,7717,7716,7714,7687,7619,7564,7553,7550,7544,7534,7527,7525,7514,7503,7477,7448,7445,7442,7441,7440,7433,7431,7425,7402,7363,7362,7360,7353,7346,7317,7314,7300,7284,7278,7269,7262,7249,7247,7238,7207,7203,7188,7186,7183,7177,7167,7166,7152,7148,7147,7141,7130,7124,7109,7097,7094,7086,7085,7068,7065,7055,7046,7041,7040,7029,7022,7021,6999,6991,6989,6977,6973,6957,6937,6930,6920,6919,6914,6912,6903,6890,6889,6881,6876,6863,6846,6831,6806,6801,6794,6792,6784,6758,6740,6733,6716,6714,6697,6696,6676,6649,6645,6640,6639,6606,6584,6567,6542,6537,6534,6530,6523,6522,6518,6517,6515,6493,6466,6462,6457,6440,6433,6426,6423,6418,6405,6369,6360,6341,6337,6336,6335,6334,6333,6332,6316,6315,6314,6305,6301,6250,6249,6243,6242,6234,6229,6215,6212,6190,6188,6182,6175,6174,6130,6128,6127,6117,6116,6115,6108,6100,6098,6093,6091,6072,6066,6059,6055,6053,6049,6048,6042,6038,6034,6022,6020,5976,5975,5974,5973,5921,5916,5915,5914,5912,5899,5885,5883,5874,5872,5871,5869,5868,5867,5866 ) AND post_status = ‘publish’ AND post_type = ‘reply’;, referer: ……../topic/going-to-try-and-post-pics/


    kvr28
    Participant

    @kvr28

    not sure why that didn’t refresh


    kvr28
    Participant

    @kvr28

    I think I found a fix

    https://gist.github.com/sc0ttkclark/8980347

    I tried on my staging site and it seems to have fixed it, I’m not very smart with this stuff, does this make sense?


    kvr28
    Participant

    @kvr28

    well, looks like that stopped the errors, but it created another issue, every time you click on a different page in the forums, it just keeps reloading the most recent posts in that forum, it doesn’t happen in most recent topic page with shortcode, the pagination works fine there, any suggestions?


    Robin W
    Moderator

    @robin-w

    try running the forum repairs

    Dashboard>tools>forums>repair and run one at a time


    kvr28
    Participant

    @kvr28

    I’ve done it several times


    Robin W
    Moderator

    @robin-w

    ok, you need to eliminate whether it is a plugin or theme issue

    Check other plugins

    Check that no other plugins are affecting this.

    Turn off all other plugins apart from bbpress, and see if that fixes the problem. If the problem is resolved, add back one at a time to see which is causing the conflict.

    Check themes

    If plugins are not the cause, then it may be a theme issue. Switch to a default theme, such as twentytwelve, and test.

    and come back and let us know


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    This is likely bbPress core, unfortunately. When you post a new reply, we check the topics for freshness so we can update the tree accordingly. We’re working on a fix for the next version, but it involves moving some metadata into the posts table to improve query performance, and we want to make sure to get it right.


    kvr28
    Participant

    @kvr28

    robin, didn’t work

    JJJ, thanks for the reply, looking forward to it

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.