Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum menu items not showing after installation


  • masopas
    Participant

    @masopas

    For some reason the menu items (Forums, Topics, Replies) are not showing up in my WordPress navigation menu after installing bbpress.

    The plugin appears to be installed and active. I do get the general forum settings under the WordPress setting menu.

    Tried several themes including TwentyEleven. Deleted and reinstalled bbpress several times.

    WP 4.3.2
    bbPress 2.2.2

Viewing 25 replies - 1 through 25 (of 26 total)

  • Lynq
    Participant

    @lynq

    Do you have a site link we can check?


    masopas
    Participant

    @masopas

    I’d have to give you access to my admin page. Nothing is showing up in the menu on the left side of the admin page. The instructions imply that new menu items show up allowing you to add Forums, etc. after you install and activity the plugin.

    Or am I confused – are the forums set up from some other location?


    masopas
    Participant

    @masopas

    Can someone please confirm that the forum setup options are supposed to appear in the main admin panel menu (the one with pages, posts, appearance, settings, etc.). Or should I be looking somewhere else?

    Thanks!


    Mohd Rafie
    Participant

    @mohdrafie

    I can confirm this happening as well.

    I have the older version of the bbpress, but as soon as I upgrade to 2.2.2, the menu disappear (no more beehive icons, beeicon, etc)

    But on the front end, the forum is still available.


    Jared Atchison
    Moderator

    @jaredatch

    What plugins are you using? Are you running any membership plugins? Have you edited any of the roles or capabilities?

    This is likely issue with bbPress 2.2.x and the user roles being changed. You can read more about it here.


    Mohd Rafie
    Participant

    @mohdrafie

    Hi Jared,

    Yes, I read the notice and I don’t actually install any plugins that manage user role.

    I hope this will be improved and I wasn’t sure why this is hidden. I should have an option to display the options back again as an admin of a site or super-admin. I’ll keep you up to date.


    Mohd Rafie
    Participant

    @mohdrafie

    As for now, I have used the Reset Forum options available and now, it forum disappear completely on the front end.

    I’ve check the Dashboard > User and I am a Keymaster (Forum Role), but I still don’t see any sign of getting the Forums, Topics available on the Dashboard menu list.


    masopas
    Participant

    @masopas

    I did not do anything with the users or roles. I tried adding a new administrator user and that didn’t help. I still don’t see the menus.

    This is a 3-year old dormant install of wordpress that I just started using again. Did all of the upgrades, etc. I did not have bbpress, that is new. But I’m thinking I should just reinstall wordpress from scratch, maybe along the way something happened related to that.

    I think we are actually talking about WP-Admin side of things not showing forums/topics/replies in the WordPress admin dashboard… Correct?

    If so it sounds like a plugin conflict and some help in narrowing this down would help all involved…

    To try and resolve conflicts with other plugins please disable all your plugins except bbPress to see if the error persists. Re-enable each plugin one at a time and if things break again you should be able to now know which other plugin is causing the conflict.


    masopas
    Participant

    @masopas

    I thought I tried that, but I guess I must have missed one – it works now. I re-enabled each plugin, but it still works, so I don’t know what happened.

    Thanks!


    vechnost
    Participant

    @vechnost

    I cant setup bbpress forum also. There is no option in menu!
    Please check as blog.
    I just tired from try set up it. Other forum WP plugins looks not so pretty as this one, but still trouble to make it working.


    vechnost
    Participant

    @vechnost

    my blog is


    RussRC
    Participant

    @russrc

    Narrowed it down to WP-ECommerce, disabling that for me shows the Forum menu option in the admin panel.

    Not sure where the fix would be


    silvias
    Participant

    @silvias

    Same problem here. I installed on a fresh WP install, no plug-ins for conflicts and no side Admin buttons. I do have the Settings, Tools but no Forums, Topics and Replies.I’ve uninstalled and re-installed but nada.

    I set up a test WP on the same host (most likely a different shared server) and installed and everything works fine. Same WP instance, no additional plug-ins etc.


    Mohd Rafie
    Participant

    @mohdrafie

    I had GD Press Tools installed. So, when I deactivate it, the menu items shows up.


    leeduguid
    Participant

    @leeduguid

    I get the same issue. Disabling my Advanced Access Manager plugin fixes it however that is not a solution (I need both). Any ideas on how this can be fixed?

    Contact the author/support site of the plugin causing the conflict and see if they can work towards making their plugin compatible with bbPress.


    leeduguid
    Participant

    @leeduguid

    Thanks will do, any ideas where I should point them?


    leeduguid
    Participant

    @leeduguid


    ckpepper02
    Participant

    @ckpepper02

    Ok, I’m having the same issue here, I’ve turned all the plugins off and I still don’t get a Forum button in the admin panel.

    I really want to use this add on, but i can’t get a darn forum added. Is there a direct link I can try so I can create a forum?

    maybe something like ../wp-admin/edit.php?post_type=bbpress


    ckpepper02
    Participant

    @ckpepper02

    GOT IT!!!

    Turns out the default forum user role was set to participant upon activation. This was blocking my access to the Forum Admin button. To get around this, I had to create a new WP user account, set it as an administrator, and the change the Forum role of my original username to Moderator. When I logged back in, I can see the Forum button.

    Hope this helps someone else!


    David
    Participant

    @dcrabill

    I don’t think the problem has to do with other plugins. It has to do with bbPress having made roles for the forums a separate thing. Look at your users page… on the right there is a “Forum Role” column. If it’s blank then that’s where your issue is. It needs to have “Keymaster”, “Moderator”, “Participant”, etc.

    For a quick fix, in Tools > Forums, you can select the checkbox for “Remap existing users to default forum roles”. If you have a lot of moderators/users, be careful. For me, it assigned all the admins to Keymaster, the moderators (bbPress used to have the role “Moderator” alongside the other WP roles) to Moderator, and everyone else to Participant.

    Get your users assigned to forum roles and the admin menus will show up for them (and you!). Only an admin can change a forum role, but they cannot change their own.


    maxime77
    Participant

    @maxime77

    Thank you David! Remapping the users fixed it on my end.


    pocome
    Participant

    @pocome

    I’ll say it again, developers have dropped a ball on this bbpress thing, I liked the idea, but turns out the implementation is lacking in more than one area. And the requirement to manual tweak the theme/template to get it to look ok isn’t up there either (I mean basic looks, not fancy fireworks).

    I am experiencing the same problem, no Forum menu in adm WD-panel, in addition to:

    1. logged in as keymaster, unable to post topics/replies (but sometimes I can), can write but on save get an error

    2. get logged out for no apparent reason

    And the fix is: DISABLE ALL your plug ins and try. People responsible for this plug in have shown an irresponsible way to deal with problems at hand. Soon enough we’ll hear: if you want bbPress, stop using other plug ins.


    pocome
    Participant

    @pocome

    Remapping users does not do jack to the Adm menu problem, not for me. I even disabled ALL plug ins that were mounted before bbPress. Still no forum menu (used to have it), no direct way to get to topics from there, it’s a mess I call it. I’m beginning to think that bbPress is the problem plug in, not the other way around.

Viewing 25 replies - 1 through 25 (of 26 total)

You must be logged in to reply to this topic.