Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum didn’t read the CSS


  • minkuei
    Member

    @minkuei

    I just setup my new forum.

    Everything works fine, but the forum didn’t ready the CSS file.

    This is how it loos now.

    http://kaespace.com/bbpress/

    I try to search the simlar topic in here and put the plugin but still didn’t work.

    Can anyone tell me what’s go wrong? thx

Viewing 11 replies - 1 through 11 (of 11 total)

  • rimian
    Member

    @rimian

    Your path setting may be blank or something.

    have a look in your config.php and check:

    $bb->path

    and

    $bb->wp_siteurl


    minkuei
    Member

    @minkuei

    I have set my config.php

    $bb->domain = ‘http://kaespace.com’;

    $bb->path = ‘/bbpress/’;

    I thought this is right setting.


    minkuei
    Member

    @minkuei

    I found out that most people’s bbpress has this code in index.php

    <link rel=”stylesheet” href=”http://yourdomain.com/style.css” type=”text/css” />

    however my index.php shows

    <link rel=”stylesheet” href=”style.css” type=”text/css” />

    in the bbpress root there is no css file, so I think that’s why it didn;t work.

    Can anyone told me how to fix it?

    Right now I just dump my css file in the root so index can reads it.


    fel64
    Member

    @fel64

    You have to do it differently. To apply a css file, make a new folder in /bbpress/ called my-templates, open it, make a new folder for your “theme”, and put in your css file called style.css. Now go to the Admin Panel > Presentation and pick your theme.

    Note that you can change the HTML output of files as well. If you do not have a file for a particular page (such as forum.php) bbpress will look for the default file (located in /bbpress/bb-templates/kakumei) and use that instead. If you wish to use a modified file, copy the default into your theme’s folder and change it there.


    minkuei
    Member

    @minkuei

    Actually I know I have to make my-templates folder and I do have it.

    But before I put css file in the root, the forum don’t even read the default theme.

    I do try to change it in admin panel, but somwhow it just don’t work.


    Trent Adams
    Member

    @trent

    Have you taken a look at this thread? As well, http://kaespace.com/bbpress/ doesn’t show up for me at all. Is that the correct address? As for the link just having “style.css” in the address, it is because it is referenced off the theme folder and not the root directory. I can’t access your site, so what is your theme as well? The default one?

    Trent


    minkuei
    Member

    @minkuei

    I was try to fix the fourm this afternoon, so if you can’t access maybe is because I was worrking on it XD.

    The Fourm address is right

    http://kaespace.com/bbpress/


    Trent Adams
    Member

    @trent

    Your site shows up fine for me in Firefox, IE, Safari, Opera and Flock. Is is still a problem on your end?

    Trent


    minkuei
    Member

    @minkuei

    Thx Trent so patience to help me out.

    Actually, yes this is still problem. I didn’t fix it and i just copy the css file from http://kaespace.com/bbpress/my-templates/kakumei_i and put it in the “http://kaespace.com/bbpress/” directory.

    When you visit my site, look at the source code and the css link shows

    <link rel=”stylesheet” href=”style.css” type=”text/css” />

    I looks others fourm’s source code they have address like http://domain.com/my-templates/kakumei/style.css in the href.

    So I am wonder, is it my config.php didn’t set it right or some other thing I have to do.

    I do put the patch-to-URL.php in my-plugins folder


    fel64
    Member

    @fel64

    You seem to have renamed the kakumei directory which would be a problem. It should be named kakumei and nothing else I think.


    minkuei
    Member

    @minkuei

    I do try to change it to kakumei, but it still not working.

    I don’t think this is the problem.

    I think it must something wrong with the setting,

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.