Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum base page different to forum index page


  • smell-bag
    Member

    @smell-bag

    Hi all,

    Why is the forum base page different from the templated forum index page I have created?

    My Forum index page works great. But in order for it to show it must have a different slug to the forum base set in the bbpress options.

    This is where things seem to be wrong – when I view my forum index i get the slug home->forums->forum-index (with forum-index being the slug of my template page)

    Surely this is very wrong, the index age should be the forum root surely? after all it is an index?

    Secondly, I cannot work out which template file is used for this mysterious “forums” base page. It’s basically a list of h2 titles with the names of all the forums in, where does it come from?

    Here are links so you can see for yourself:

    my index page:

    http://lazybricks.blueleafstudio.net/forum-index/

    the forum base page:

    http://lazybricks.blueleafstudio.net/forums/

    Try clicking the root link in the breadcrumbs (the one next to home), it switches between the two! Odd behaviour indeed.

    I only want the forum index to show, that should be the ‘root’ or ‘base’ of the forums. However if i give my index page the same slug as the forum base (i.e. forums) then i get the page i don’t want, not the pretty templated one.

    I have been stuck on this one thing for a whole day after creating a lovely index page and I don’t want to be stopped by this!

    If anyone can help it would be very much appreciated,

    Thanks in advance

You must be logged in to reply to this topic.