Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal Error?


  • ironbound
    Member

    @ironbound

    I am getting the following error and I don’t understand why:

    Fatal error: main() [function.require]: Failed opening required ‘./wordpress/wp-blog-header.php’ (include_path=’.:/usr/local/lib/php’) in /homepages/19/d158184300/htdocs/index.php on line 4

    Please help me solve this.

Viewing 13 replies - 1 through 13 (of 13 total)

  • chrishajer
    Participant

    @chrishajer

    Remove the line where you are trying to include the wp-blog-header.php and things will work fine. What are you trying to accomplish with that?


    ironbound
    Member

    @ironbound

    I didn’t add that anywhere. I’m doing a basic install. I don’t know where it is getting that from. I checked install.php and nothing.


    ironbound
    Member

    @ironbound

    The problem is that I have this stupid shared hosting BS with 1and1. Right now I have mysite.com which is actually mysite.com/forum. Then I have the files under mysite.com/forum/bbpress. It installs fine but then I get 500 errors on any of the forum links.


    ironbound
    Member

    @ironbound

    Thank you for your help chrishajer. I did eventually figure it out… after 13 different installations. It was easy (bbpress) but shared hosting is difficult to deal with.


    chrishajer
    Participant

    @chrishajer

    I use 1&1 without any trouble with many bbPress and WordPress installations. If you need help, just post. Every host is a little bit different, but I have 3+ years of experience with 1&1 on all types of servers.

    Cheers.


    ironbound
    Member

    @ironbound

    Chris: Although my forum is working right now. It is not doing what I want it to do. Let me explain what I want to accomplish and then my current setup. I have 1&1 shared hosting.

    I would like mysite.com to be directly forwarded to the forum. Meaning if I type mysite.com it goes to the forum’s main page.

    Right now (the only way I made everything work) mysite.com is just at the root folder and displays nothing (the 403 error because there is now index in the main root directory). The forum is at /forums and works. But i have to type mysite.com/forums.

    The config file was setup for http://mysite.com/forums/

    inside /forums/ you find the bb-admin and folders etc. Basicly I renamed bbpress as forums and installed it from there.

    The problem is that is I forward the mysite.com domain to either the /forums/ directory or do an HTTP forward. It does not work. It messes everything up. I am clearly doing something wrong. I can’t understand shared hosting. ahhhhhhhhh. Please help me. Buy you a latte.


    chrishajer
    Participant

    @chrishajer

    You can make that change in your 1&1 control panel. Administration > Domains > click the domain name, click the Destination [Edit] button, then select the /forums/ directory from the “Existing directory” select box. That directs all traffic destined for mysite.com to whatever website you have installed in the forums directory (which is bbPress in this case.)

    That works fine if you want your bbPress installation to be the whole website mysite.com and everything is in the ‘forums’ directory. It’s the most direct way to do it, since you have the option to do it this way. It basically hides the fact that things are in a ‘forums’ directory, just like all the rest of the web server path is hidden. My full path is something like /kunden/homepages/46/d93680635/htdocs, and then each website has a subfolder there.

    /kunden/homepages/46/d93680635/htdocs/chrishajer/

    /kunden/homepages/46/d93680635/htdocs/forums/

    /kunden/homepages/46/d93680635/htdocs/somesite/forums/

    Your subfolder will be called “forums”, but people visiting your site will never know.

    Coffee – black :)


    ironbound
    Member

    @ironbound

    Yep. That’s what I thought. BUT when I do that, the site loses all the formating. Take a look: http://ironboundforum.com/


    chrishajer
    Participant

    @chrishajer

    You have the wrong URI in your config.php. You have this (I think):

    // The full URL of your bbPress install
    $bb->uri = 'http://ironboundforum.com/forums/';

    and it should be

    $bb->uri = 'http://ironboundforum.com/';

    bbPress doesn’t care if it’s in a folder or not, just like it doesn’t know that it’s in your webroot of /kunden/homepages/46/d93680635/htdocs/ironbound/, so that ‘forums’ portion does not need to be in the config.php for your URI.

    See this after I applied the proper stylesheet:

    http://www.chrishajer.com/bbpress/Ironbound.png


    chrishajer
    Participant

    @chrishajer

    Now it’s up to two coffees :)


    ironbound
    Member

    @ironbound

    Do I have to reinstall or just edit config?


    ironbound
    Member

    @ironbound

    WOW!!!! It works! haha this is amazing! Do you have like a paypal id or amazon where i can send you some coffee money?


    chrishajer
    Participant

    @chrishajer

    No need – just glad it’s working. We’ll call it virtual coffee money :)

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.