Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal error on my theme


  • tegolino
    Member

    @tegolino

    I’m trying to set the theme of my blog in bbpress

    I have followed all rules, but this is my error:

    Fatal error: Call to undefined function: get_settings() in /web/htdocs/www.motiongraphics.it/home/forum/my-templates/mw1.1/themetoolkit.php on line 331

    Why?!

Viewing 9 replies - 1 through 9 (of 9 total)

  • tegolino
    Member

    @tegolino

    ops! sorry, the full and right path is

    Fatal error: Call to undefined function: get_settings() in /web/htdocs/www.motiongraphics.it/home/forum/

    my-templates/mw1.1/themetoolkit.php on line 331


    tegolino
    Member

    @tegolino

    On line 331 I have:

    $them = get_settings(‘active_plugins’);


    chrishajer
    Participant

    @chrishajer

    I just created a login at http://www.motiongraphics.it/forum/ and everything worked fine. I was able to do login and create a topic just fine.

    The really weird thing is that the forum initially looked like a standard bbPress install (kakumei or whatever that theme is called) then, after I created a topic, it switched over to what looks like this bbpress.org forum theme. It was so disorienting, I thought I posted on bbpress by mistake!

    So, unless you were messing with the templates, something weird is going on. However, I did not see the error you mentioned, I just had the weirdness with the differing templates.

    Sorry for my Italian :)


    chrishajer
    Participant

    @chrishajer

    Do you have a my-templates directory? Is there anything in it?


    tegolino
    Member

    @tegolino

    ops sorry for the swiching! I’m doing a tests!

    I have my-templates folder, but I want the same theme of my blog http://www.motiongraphics.it . When I switch to MW theme the error is

    Fatal error: Call to undefined function: get_settings() in /web/htdocs/www.motiongraphics.it/home/forum/

    my-templates/mw1.1/themetoolkit.php on line 331

    :((((


    fel64
    Member

    @fel64

    Tegolino, are you also motiongrapher? Because I believe there was someone here called motiongrapher looking for help with motiongraphics.it too.

    Why is that line even there? Is it necessary? You may be able to just comment it out.


    tegolino
    Member

    @tegolino

    sorry I’m also motiongrapher, but I lost my password and so I register me again

    ok, I try to remove that line


    tegolino
    Member

    @tegolino

    it doesn’t work :(


    fel64
    Member

    @fel64

    What’s the new error?

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.