Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error when deleting entire topic…


  • fokjulle
    Member

    @fokjulle

    What is this, and how do I fix it?

    **************

    bbPress database error: [Illegal mix of collations (utf8_general_ci,COERCIBLE) and (latin1_swedish_ci,IMPLICIT) for operation 'find_in_set']

    SELECT user_id, meta_value FROM bb_usermeta WHERE meta_key = ‘favorites’ and FIND_IN_SET(’3′, meta_value) > 0

    Warning: Cannot modify header information – headers already sent by (output started at /usr/www/users/trashm/forums/bb-includes/db-mysql.php:106) in /usr/www/users/trashm/forums/bb-includes/pluggable.php on line 224

Viewing 14 replies - 1 through 14 (of 14 total)

  • chrishajer
    Participant

    @chrishajer

    I have no idea what that is, but I can try and help until someone more knowledgeable comes along.

    Did you set any of these three lines to something different than the default in your bb-config.php:

    define('BBDB_CHARSET', 'utf8');
    define('BBDB_COLLATE', '');
    define('BB_LANG', '');

     

    I found this online:

    http://www.datutorials.com/mysql/mysql_ref_manual_Charset.php

    What is your MySQL version?


    Sam Bauers
    Participant

    @sambauers

    I imagine you have this set in your bb-config.php:

    define('BBDB_COLLATE', 'utf8_general_ci');

    .

    When it should be (in your case):

    define('BBDB_COLLATE', 'latin1_swedish_ci');


    fokjulle
    Member

    @fokjulle

    I have the latest MySQL, or, my host company, at least, does. They’re very good that way. I’ve tried the above fixes, and nothing works. I’ve adjusted nothing in my config file.

    Also, I’m not Swedish, so I’m not sure why anything needs to be Swedish…


    fokjulle
    Member

    @fokjulle

    If anyone can help, here is my forum.


    Sam Bauers
    Participant

    @sambauers

    Can you post the database section of your bb-config.php here (the first 15 or so lines). Turn anything sensitive, like the password, into ********.


    chrishajer
    Participant

    @chrishajer

    Maybe the database you used for WordPress has a different collation, but WordPress didn’t care about the difference where bbPress does care and gives you an error?

    Do you have access to the database with something like phpMyAdmin?


    fokjulle
    Member

    @fokjulle

    Here is config.php:

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘*********’); // The name of the database

    define(‘BBDB_USER’, ‘********’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘*********’); // …and password

    define(‘BBDB_HOST’, ‘**********’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old bb-config.php does

    define(‘BBDB_COLLATE’, ”);

    define(‘BB_LANG’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change BB_SECRET_KEY to a unique phrase. You won’t have to remember it later,

    // so make it long and complicated. You can visit https://www.grc.com/passwords.htm

    // to get a phrase generated for you, or just make something up.

    // If you are integrating logins with WordPress, you will need to match the value

    // of the “SECRET_KEY” in the WordPress file wp-config.php

    define(‘BB_SECRET_KEY’, ”); // Change this to a unique phrase.

    // If you are running multiple bbPress installations in a single database,

    // you will probably want to change this.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BB_LANG to ‘de’

    // to enable German language support.

    define(‘BB_LANG’, ”);

    /* Stop editing */

    if ( !defined(‘BB_PATH’) )

    define(‘BB_PATH’, dirname(__FILE__) . ‘/’ );

    require_once( BB_PATH . ‘bb-settings.php’ );

    ?>

    Yes, I use PHPMyAdmin…


    fokjulle
    Member

    @fokjulle

    Has someone had a chance to look at this?…


    chrishajer
    Participant

    @chrishajer

    Sounds like the collation on some tables or fields in the database don’t match some others. I think they should all be the same. If you log in with phpMyAdmin, you should be able to check what the database collation is, then make all the tables and fields the same.

    This is only a guess though, but if it were my forum and my error, that’s what I would do.


    fokjulle
    Member

    @fokjulle

    I have no idea what you’re talking about…


    Sam Bauers
    Participant

    @sambauers

    Try editing this line in your bb-config.php file.

    define('BBDB_COLLATE', '');

    .

    To this:

    define('BBDB_COLLATE', 'utf8_general_ci');


    fokjulle
    Member

    @fokjulle

    Still throwing the same error message…


    _ck_
    Participant

    @_ck_

    The word “swedish” is in there only because MySQL was originally a Swedish product and it’s legacy. Has nothing to do with any local language settings – just means it’s at the default.

    Perhaps a database upgrade failed at some point and left it at a weird miss-match?


    fokjulle
    Member

    @fokjulle

    Well, everything installed smoothly, so I don’t know what more to say…

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.