Skip to:
Content
Pages
Categories
Search
Top
Bottom

ERROR: Could not establish a database connection


  • gregfielding
    Participant

    @gregfielding

    I paid for BBPress integration with WPMU from wp.mu and I don’t think the job was done right…but I’m hoping it’s an easy fix.

    All of the files exist, but I get this message ERROR: Could not establish a database connection

    Any thoughts?

Viewing 8 replies - 1 through 8 (of 8 total)

  • gerikg
    Member

    @gerikg

    contact them and tell them to fix it since you paid for it. If they can’t get your money back and then contact me I can walk you through it or just search it online.


    gregfielding
    Participant

    @gregfielding

    Is it as simple as making some changes in the bb-config file?


    gerikg
    Member

    @gerikg

    look in your bb-config.php & wp-config.php make sure they are all correct.


    gregfielding
    Participant

    @gregfielding

    Fixed it…Thanks!

    Now I’ve got a new problem…I made it all the way through step 3 and the integration. Then, as it actually began the installation, an error message came up saying that I had to manually re-define the auth-key, secure auth-key and one other one. It said installation cancelled.

    What is “re-defining?” The number sequences are right.

    How do I get the installation to start again?

    When I visit the install site, I get

    Oh dear!

    bbPress is already installed.

    Perhaps you meant to run the upgrade script instead?


    chrishajer
    Participant

    @chrishajer

    For your new problem, please start a new topic.

    Hello,

    I have uploaded bbPress to my site started the install process, but I get this message:

    There was a problem connecting to the database you specified.

    Please check the settings, then try again.

    Not sure what to do?


    chrishajer
    Participant

    @chrishajer

    You need to make sure you have all the settings correct. One thing that gets many people is that once they have the username, database name and password done, they still need to enter the database host. The space to enter that, instead of localhost, is not shown by default and there is a link to click, something like “show advanced database settings.” Do you need to use a database host other than localhost?


    TristanOBAv
    Member

    @tristanobav

    gregfielding, how did you fix the database connection error? I’m having the same problem, thanks.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.