Skip to:
Content
Pages
Categories
Search
Top
Bottom

Editing Replies loses parent


  • maf2874
    Participant

    @maf2874

    hi – using wp 3.3.1 BBP – 2.0.2 i’m running into problems when editing replies. when i save it loses it’s parent association as the content of the TOPIC pulldown field usually says (no topic) -

    enter image description here

    we have many many topics but they dont default when in the edit screen.
    is this a BBPress bug and/or has this been fixed in the newer releases?

    (i believe we lose the original author reference also.)

    thanks!

Viewing 3 replies - 1 through 3 (of 3 total)

  • imjscn
    Participant

    @imjscn

    Apology if I am spoiling your thread, but I do have a question about bbpress post parent, maybe our question is related to the same answer, so, let me go on… In WP, if we want to find a post parent, we do
    $post=get_post($id)
    $parent_id= $post->post_parent
    In bbpress, there is a fundtion to do the job

    function bbp_get_reply_topic_id( $reply_id = 0 ) {
    
        // Assume there is no topic id
        $topic_id = 0;
    
        // Check that reply_id is valid
        if ( $reply_id = bbp_get_reply_id( $reply_id ) )
    
            // Get topic_id from reply
            if ( $topic_id = get_post_meta( $reply_id, '_bbp_topic_id', true ) )
    
                // Validate the topic_id
                $topic_id = bbp_get_topic_id( $topic_id );
    
        return apply_filters( 'bbp_get_reply_topic_id', (int) $topic_id, $reply_id );
    }
     My question is-- why bbpress does not use WP's post\_parent, instead, it saves parent\_id in child's meta, make no use of native WP post table? The parent may got lost somewhere in the middle of the additional out of system steps.
    

    maf2874
    Participant

    @maf2874

    My fix:
    In plugins/bbpress/bbp-admin/bbp-metaboxes.php function bbp_reply_metabox at the //topics section I increased the value in ‘numberposts’ => ’5000′

    The default limit of 250 was too low for my site.


    Anointed
    Moderator

    @anointed

    I have the same problem. I tried 5000 but that didn’t work, probably because I have 380k topics, so I tried 300k, that froze my site completely out of memory error.

    I wonder how we would ever solve this problem for medium sized sites. I can’t imagine having to load a half million rows to reassign a reply to a topic, that’s insane.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.