Skip to:
Content
Pages
Categories
Search
Top
Bottom

Edit time allowed issue, BUG


  • ronthai
    Participant

    @ronthai

    Hi,
    I have a small problem with the allowed edit time for participants.
    At first it never showed up, until I set it to 600 minutes (standard I had 60min)

    So I tried to increase the settings by 60 minutes to see when the edit link would show.
    For me it is 420+ minutes. 420 minutes is 7 hours and my WP/Forum is set to UTC +7.00 hours.

    So I solved it by setting the allowed edit time to 480 minutes, which gives participants in reality 60 minutes.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am testing this now but I cannot reproduce it.

    Do you the correct time zone +7UTC set in WordPress’ settings?

    http://example.com/wp-admin/options-general.php


    ronthai
    Participant

    @ronthai

    Yes, UTC+7 in options-general.php

    I have the time display on custum (j F Y), but that should not interfere.


    ronthai
    Participant

    @ronthai

    I just did some more checking and set the UTC to the standard UTC+0

    That made no diference on new posts edit time, still had to set it above 420 minutes.
    I think this means that the edit time is related to the IP address/location, since my location is UTC+7

    To test this you could use a VPN and pretend to be in an other location/timezone.


    ronthai
    Participant

    @ronthai

    Nevermind, I found the problem. I remembered I did this before:

    I have a statistics plugin that uses the server time instead of the WP timezone settings.

    Therefore I added <?php date_default_timezone_set('Asia/Bangkok'); ?> to the plugins php and that was in the sidebar always present.

    Now I removed it the Edit Allowed Time works correct.

    Cool, thanks for the update :)

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.