Skip to:
Content
Pages
Categories
Search
Top
Bottom

Edit button edits all posts on site


  • ThePhat32
    Participant

    @thephat32

    I have a huge issue ATM on my install. One of my users reported that when editing their post it came up with all the posts of my site to edit. Not the forum post but the front page article posts.

    The issue was reported here: http://pixelsedge.net/topic/edit-button-problem

    I am using BuddyPress 1.5.6, bbpress 2.1.2 and s2member 120703. They all have ties together so I thought I would list them. Any help would be great as this is presently a HUGE issue

Viewing 5 replies - 1 through 5 (of 5 total)

  • ThePhat32
    Participant

    @thephat32

    Any chance this can be looked at or answered? This is kinda a huge issue……..

    Are you using the latest versions of bbPress/WordPress?

    I’ve never heard of this happening at all since 2.0 has been released. I have no cluet what’s going on, but we’re going to need a lot more information.

    Can you duplicate this?

    We need to know the steps taken to “break” it. Specifically, what “edit” link did she click? On what post? When it took her to the edit page, what was the full URL? That sort of information.

    You need to ask the user for step by step direction on how this occurred. We need to duplicate it to see if it is indeed a real bug or just something breaking on your site due to a theme/plugin conflict. :)


    ThePhat32
    Participant

    @thephat32

    I am using the latest wordpress and latest bbpress.

    I can recreate it. It was the first thing I did before posting here in fact :P. Being a software dev it was step 1. I created a new user account the same as all my users, I made a post on a forum and also tried replying to 1. I then clicked the edit button, it opened the edit form which showed all of the wordpress posts. When I use my Key Master account, I don’t see this, I am able to edit properly. Same goes for my other admins who have been editing there posts

    • This reply was modified 1 year, 10 months ago by  ThePhat32.

    Man this is weird. I think its a plugin or the theme hijacking the query or something which is making bbPress go haywire.

    Two things to do to narrow down the problem.

    1) Temporarily switch you theme (just for a moment) to TwentyTen. Does the problem still happen? If no, then your theme is conflicting with bbPress, if yes this proceed to 2.

    2) Temporarily disable all plugins other than bbPress. It will likely start working when they are all disabled if you got this far. Then turn them on one by one until you find the culprit.


    ThePhat32
    Participant

    @thephat32

    I just changed the theme and it seemed to work with my test account. Seems I will have to talk to the theme makers and see if they can fix the issue. Thanks for the heads up :)

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.