Skip to:
Content
Pages
Categories
Search
Top
Bottom

Database Upgrade Issues


  • citizenkeith
    Participant

    @citizenkeith

    When I moved to a new host (Media Temple), I also upgraded to RC1. I skipped RC2 and I’m currently running RC3.

    Ever since I switched, I have had three occasions in which bbPress informed me that I needed to upgrade the database. I get this message when I go to the admin panel. Fist I notice that certain plugins aren’t activated (which were activated previously), and so I go to the admin panel and get the upgrade massage.

    Here are the upgrade messages:

    Beginning upgradeā€¦

    Tags copied to taxonomy tables: bb_upgrade_1080

    Display names populated: bb_upgrade_1090

    Index forum_stickies dropped: bb_upgrade_1100

    >>> Done

    Is this a problem with my host? A bbPress bug? Hacking? Could it be related to my recount problem (see my previous post for info)?

    Thanks in advance…

Viewing 6 replies - 1 through 6 (of 6 total)

  • citizenkeith
    Participant

    @citizenkeith

    And now I posted and got this message:

    Database error: [Out of memory (Needed 2093072 bytes)]

    SELECT DISTINCT poster_id FROM bb_posts WHERE topic_id = ’271′ AND post_status = ’0′;

    Caller: bb_new_post, bb_insert_post

    Warning: Cannot modify header information – headers already sent by (output started at /nfs/c04/h04/mnt/68418/domains/mydomain.com/html/forums/bb-includes/backpress/class.bpdb.php:569) in /nfs/c04/h04/mnt/68418/domains/mydomain.com/html/forums/bb-includes/functions.bb-pluggable.php on line 226


    johnhiler
    Member

    @johnhiler

    I am also on MediaTemple. Do you have a dedicated server, or are you on the grid?


    citizenkeith
    Participant

    @citizenkeith

    I’m using the grid.

    I opened a ticket with MT, so I’ll report back with their response.


    johnhiler
    Member

    @johnhiler

    Ah ok. We’re using a dedicated server…

    This post reported that MT grid uses NFS, which supposedly isn’t good for bbPress?

    http://bbpress.org/forums/topic/mysql_connect-cant-connect-through-socket

    I used MT grid for a long time and had a lot of problems. But it could’ve been their growing pains, which I hear they’ve grown past. We’ve had a great experience with their dedicated servers, although it’s a totally different setup.

    That topic also mentioned a tweak that the user made just for the 1.0 alpha on the MT grid – dunno if that would help at all, but thought I’d share the link anyway.


    citizenkeith
    Participant

    @citizenkeith

    Thanks John, I’ll check it out.

    MT reported back saying they could not recreate the problem. They ran some tests but came up empty.


    bforeste
    Member

    @bforeste

    citizenkeith: did you ever resolve your issue?

    I’m having similar (DB connection…DB upgrade requests) and I’m on MT GS, trying to upgrade from 0.9 to 1.0.2

    http://bbpress.org/forums/topic/upgrade-errors-it-looks-like-your-database-is-out-of-date

    Just looking for some extra information before I wipe out the 1.0 install dir and try again clean from the top.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.