Skip to:
Content
Pages
Categories
Search
Top
Bottom

Database error

  • When trying to post I get this message:

    bbPress database error: [Unknown column 'post_title' in 'field list']

    UPDATE bb_posts SET post_title=’Testy mctest test’ WHERE post_id=’11

    I am using the wordpress database (different prefix for bb stuff) but there doesn’t seem to be a post_title column, here’s the output from mysql:

    mysql> describe bb_posts;

    +


    +


    +


    +


    +


    +


    +

    | Field | Type | Null | Key | Default | Extra |

    +


    +


    +


    +


    +


    +


    +

    | post_id | bigint(20) | NO | PRI | NULL | auto_increment |

    | forum_id | int(10) | NO | | 1 | |

    | topic_id | bigint(20) | NO | MUL | 1 | |

    | poster_id | int(10) | NO | MUL | 0 | |

    | post_text | text | NO | MUL | | |

    | post_time | datetime | NO | MUL | 0000-00-00 00:00:00 | |

    | poster_ip | varchar(15) | NO | | | |

    | post_status | tinyint(1) | NO | | 0 | |

    | post_position | bigint(20) | NO | | 0 | |

    +


    +


    +


    +


    +


    +


    +

    9 rows in set (0.00 sec)

    I have looked around, but can’t seem to find anything about it on here. The forum/topic actually shows up when I go back to the page, but this is rather inconvenient. Thanks to anyone willing to help out with this.

    WP version = 2.51

    MySQL version = Server version: 5.0.45-Debian_1ubuntu3.3-log Debian etch distribution

    bbPress version = latest (just got it 3 or 4 days ago) so 0.9.0.2

    Thanks,

    -Scott.

Viewing 3 replies - 1 through 3 (of 3 total)

  • chrishajer
    Participant

    @chrishajer

    Are you using any plugins? That column is not in my 0.9.0.2 installation either. Maybe it’s trying to insert into the wp_posts table; there is a post_title field in that table.

    Yeah I thought of that, haven’t tried to unload all of the plugins yet, there needs to be a disable all like wp ;). I’ll try and post my results. Thanks for the help.

    Yup figured it out, god I love grep and schtuff. It was a plugin called Add titles to replies (pb–add-titles-to-replies) it tried to modify the table but wasn’t successful, deactivated and everything works fine, thanks for the help.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.