Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can’t get bbpress to install

  • I have had bbpress working on my doteasy account, and I decided to reinstall it – probably shouldn’t have :( When I contacted them, they informed me that they would try running the script and installing it…and I got this message back

    “Hello Antonio,

    This script appears to be incompatible with our hosting servers. Please try using a different script.”

    “The database failed to install. You may need to replace bbPress with a fresh copy and start again.”

    Now here is what happens when I try to install the script.

    Your site settings have been saved and we are now ready to complete the installation. So what are you waiting for?

    Then when I proceed to the final step I get this error.

    “Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, advancedsupport@doteasy.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.”

    At this point, if I refresh the page it goes back to the installer and I get this message ” bbPress Installation

    Welcome to the bbPress installer

    Step 1 – Database configuration

    « completed

    Step 2 – WordPress integration (optional)

    « skipped

    Step 3 – Site settings

    Installation complete!

    Show installation messages: “

    If I then go back to atriskstoriesofhope.com/bbpress it wants to go back through the installation. What should I do?

Viewing 11 replies - 1 through 11 (of 11 total)

  • chrishajer
    Participant

    @chrishajer

    Which hosting account do you have from Doteasy? The free one does not have PHP and MySQL, I don’t think. Their Ultra and above accounts do. It appears you have a Linux hosting account with them, which is good.

    bbPress has fairly minimal requirements from a host:

    * PHP 4.3 or greater

    * MySQL 4.0 or greater

    I can’t imagine a Linux hosting account that doesn’t meet those requirements. So what exactly does Doteasy mean by “incompatible”? I think you need to talk to them more.

    Also, what happens if you just go and finish the installation? Does it work, or error out?

    One last thing: do you have access to webserver logs to see what that Internal Server Error is? That might be key.

    “Step 3 – Site settings

    « completed

    Installation failed!

    ! The database failed to install. You may need to replace bbPress with a fresh copy and start again. “

    Heres what I got from them.

    “Please ask the creator of this script for further assistance as Doteasy does not provide web design or development services.

    Here is the site error log for today.

    [Mon May 05 08:19:23 2008] [error] [client 65.61.193.36] php-script: line 4: 22269 Segmentation fault /usr/bin/php-cgi, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3

    [Mon May 05 08:19:23 2008] [error] [client 65.61.193.36] Premature end of script headers: php-script, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3


    chrishajer
    Participant

    @chrishajer

    Sounds like something is wrong with the database tables. It’s trying to reuse tables that are there but there is some sort of problem. Can you drop those tables (if there is no content there) and then start the installation again?

    I already tried that. Baffled…


    chrishajer
    Participant

    @chrishajer

    I can help if you contact me off list. Find contact details on the site linked to my profile.

    I still can’t get bbpress to install. I tried to contact chrishajer off list, but I havn’t gotten a response.

    “Please ask the creator of this script for further assistance as Doteasy does not provide web design or development services.

    Here is the site error log for today.

    [Mon May 05 08:19:23 2008] [error] [client 65.61.193.36] php-script: line 4: 22269 Segmentation fault /usr/bin/php-cgi, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3

    [Mon May 05 08:19:23 2008] [error] [client 65.61.193.36] Premature end of script headers: php-script, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3

    Here let me see if I can try to explain this a little bit better

    Here goes…I ran the installer up to this point…

    Step 3 – Site settings

    » Your site settings have been saved and we are now ready to complete the installation. So what are you waiting for?

    and I got this error after I try to proceed to step 4

    “Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.”

    Then I went back one page and tried to complete step 3 and I got this…

    “Step 3 – Site settings

    « completed

    Installation failed!

    ! The database failed to install. You may need to replace bbPress with a fresh copy and start again. “

    These are the errors that I’ve gotten from the error log.

    [Sun May 18 01:12:00 2008] [error] [client 66.8.172.162] php-script: line 4: 4269 Segmentation fault /usr/bin/php-cgi, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3

    [Sun May 18 01:12:00 2008] [error] [client 66.8.172.162] Premature end of script headers: php-script, referer: http://www.atriskstoriesofhope.com/bbpress/bb-admin/install.php?step=3

    not sure what to do???


    chrishajer
    Participant

    @chrishajer

    Please try contacting me again. I’m pretty much around all the time. Maybe it’s a problem with the timezone difference.


    elorgwhee
    Member

    @elorgwhee

    I received a very similar error (something about the database and needing to try to reinstall) when trying a fresh install and integrating wordpress at the same time. I retried it a few times – each time it would fail, and if I tried to access the forum location it would bring me to the installation script again.

    Eventually I went through the installation without integrating wordpress and I that’s what ultimately worked. I then went through the wordpress integration after the install.

    Latest wordpress & bbpress, on Linux, PHP 5.2.5, MySQL 4.1.22.


    dallasbpeters
    Member

    @dallasbpeters

    Same problem. No luck here.

    MySQL 4.0.23

    PHP 4.4

    Hmmm.


    dallasbpeters
    Member

    @dallasbpeters

    Ok. I got an error when looking for the config file because I did not have an .htacess file in the root. So I manually uploaded the config.php file and now it seems to be working without the .htacess file.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.