Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can't enable user themes


  • piedpiper21
    Member

    @piedpiper21

    Themes in the my-templates directory don’t seem to be applied correctly. They can be read but the thumbnail shows a blank image. When I apply, the forum works, but without any graphic element whatsoever. Looks as though it’s coded in html with the Times font.

Viewing 20 replies - 1 through 20 (of 20 total)

  • _ck_
    Participant

    @_ck_

    Trying switching to the built in kakumei and then back to your theme.

    Make sure each of your themes is in it’s own directory under my-templates

    ie. my-templates/kakumei/

    Make sure ALL the files are in that kakumei directory.

    If all that fails, do a “view source” on your page and look for the line like:

    <link rel="stylesheet" href=" blah

    and see where it is trying to load the stylesheet from.


    piedpiper21
    Member

    @piedpiper21

    Okay, I’ve triple checked everything.

    <link rel=”stylesheet” href=”http://roadtoanimation.com/forums/my-templates/kakumei/style.css” type=”text/css” />

    It’s linking to the desired file. And that file exists in the required directory. Still no results. Am I missing something here?

    And _ck_ thank you for all your help today. I admire your dedication.


    _ck_
    Participant

    @_ck_

    That file is not there like you think it is:

    http://roadtoanimation.com/forums/my-templates/kakumei/style.css

    It’s a 404.

    But it might be wordpress interfering with the forums directory since WP is in your webroot.

    Strange that it would happen with a static file though.

    Triple check that you have

    /forums/my-templates/kakumei/style.css

    via FTP, make absolutely sure it’s there.

    If it is indeed there, download your .htaccess file in your top directory (where WP is) and post it here.


    piedpiper21
    Member

    @piedpiper21

    Yep, it’s there. Here’s my .htaccess:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress


    _ck_
    Participant

    @_ck_

    I believe wordpress is trying to process the request because you have bbPress nested underneath WordPress which is a less common method of integration.

    Try changing that .htaccess to this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !^forums/
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Not quite sure I have that right but give it a go and let’s see.

    If it doesn’t work try replacing the forums/ line with this one:

    RewriteCond %{REQUEST_URI} !^forums/


    _ck_
    Participant

    @_ck_

    I’m sorry to keep asking but are you 1000% sure you don’t have a typo in the directory name?

    Because this one works:

    http://roadtoanimation.com/forums/bb-templates/kakumei/style.css

    and I don’t see why this wouldn’t, unless it’s a typo on your ftp:

    http://roadtoanimation.com/forums/my-templates/kakumei/style.css

    Is style.css spelled correctly in the filename in the ftp?

    Then again the embedded url is generated from the directory it’s in, so in theory, even with a typo it would still work. So we are back to looking at htaccess since I am out of other ideas.


    piedpiper21
    Member

    @piedpiper21

    Nope, no luck either way.


    piedpiper21
    Member

    @piedpiper21

    Well, why can’t I just use the core folder for my themes?

    Can that work? Two themes named kakumei? I’d be inclined to rename the my-templates one to ‘piedkakumei’ or something.


    _ck_
    Participant

    @_ck_

    You can rename the sub-folder anything you want and yes you can even put it into bb-templates though that’s not how it’s supposed to be done.

    It’s just a bad sign that my-templates doesn’t work and very mysterious.

    There might be something else going on like multiviews interfering.


    piedpiper21
    Member

    @piedpiper21

    I see. Well, alright, you mentioned that having bbpress nested underneath wordpress is a less common method of installation. How should I go about reinstalling it in the usual manner?


    _ck_
    Participant

    @_ck_

    It’s less common but it’s not invalid at all. There are many installs that do it.

    To just move forward so you can work on other things I would simply try putting the copy of kakumei under bb-templates and see if even that works. Name it maybe mykakumei for example.


    Gautam
    Member

    @gautam2011

    Try chmodding it to 755 and see if it works then….


    piedpiper21
    Member

    @piedpiper21

    Gautam: How would I do that?

    ck: Alright, as of now, I’m running the modified kakumei theme from my bb-templates folder. I have a backup of the original files in the my-templates folder. Are there any potential issues I need to be aware of before proceeding like this?

    I suppose I’ll devote more time to solving this after I’ve customised this theme to my liking and can apply it to another.


    thekmen
    Member

    @thekmen

    Looks like you are still using the default kakumei theme in bb-templates/kakumei.

    As well as renaming your modified template in my-templates/ have you edited that themes style.css to reflect the new name? then selected that new name in your admin/themes selection?


    chrishajer
    Participant

    @chrishajer

    These folders do not exist:

    http://roadtoanimation.com/forums/my-plugins/

    http://roadtoanimation.com/forums/my-templates/

    These do:

    http://roadtoanimation.com/forums/bb-plugins/

    http://roadtoanimation.com/forums/bb-templates/

    (BTW, you should turn off directory indexes by putting this in your .htaccess:

    Options -Indexes )

    Since that server appears to be running Apache/Linux, the directory names are case sensitive. Are you sure they’re lowercase? Also, using hyphens, not underscores? Can you take a screenshot of the directory listing, using a shell or FTP, and post a link to that? Or, find someone local who you trust that can log in and check this out for you.


    piedpiper21
    Member

    @piedpiper21

    Okay, here’s a screenshot of my forums directory

    http://roadtoanimation.com/wp-content/uploads/2009/07/FOLDERS.jpg


    _ck_
    Participant

    @_ck_

    I don’t know why I didn’t think of it but Gautam is absolutely right.

    Try chmod 755 on your my-templates and my-plugins folders.

    They are currently at 750 as you can see in your screenshot.


    johnhiler
    Member

    @johnhiler

    Here are some instructions on how to change your file permissions using an FTP client:

    http://codex.wordpress.org/Changing_File_Permissions#Using_an_FTP_Client


    piedpiper21
    Member

    @piedpiper21

    Yep, that’s it. The permission mode was the error.

    Thanks!

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.