Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cannot Edit Users


  • aaironman
    Member

    @aaironman

    I’ve just installed bbPress and depply integrated with WordPress. All was well until I renamed the file folder to “forums” from “bbPress”. Everything is working perfectly except I cannot edit user profiles! They can register and all else seems to work on the site and the Admin, just no editing the user profile pages (either from the forum or from admin).

    When I attempt to edit user profile it switched to my WordPress and gives me a “Error 404: Page Not Found”.

    Here is a sample URL: “http://jernigan.co/forums/profile/admin”

Viewing 8 replies - 1 through 8 (of 8 total)

  • aaironman
    Member

    @aaironman

    By the way, I’m running Linux/4GH, PHP 5.x, MySQL on godaddy.com. I have the latest versions of WordPress (3.1) and bbPress(1.0.3) installed.


    aaironman
    Member

    @aaironman

    By the way, I’m running Linux/4GH, PHP 5.x, MySQL on godaddy.com. I have the latest versions of WordPress (3.1) and bbPress(1.0.3) installed.


    aaironman
    Member

    @aaironman

    Good now – all you have to do is turn off permalinks after you move a directory.

    If you want the Permalinks options to work, you have to change the “options-permalinks.php” file. Mine initially looked like this:

    **********

    $permalink_options = array(

    ‘mod_rewrite’ => array(

    ‘title’ => __( ‘Permalink type’ ),

    ‘type’ => ‘radio’,

    ‘options’ => array(

    ’0′ => sprintf( __( ‘<span>None</span> %s‘ ), bb_get_uri( ‘forums.php’, array( ‘id’ => 1 ), BB_URI_CONTEXT_TEXT ) ),

    ’1′ => sprintf( __( ‘<span>Numeric</span> %s‘ ), bb_get_uri( ‘forums/1′, null, BB_URI_CONTEXT_TEXT ) ),

    ‘slugs’ => sprintf( __( ‘<span>Name based</span> %s‘ ), bb_get_uri( ‘/forums/first-forum’, null, BB_URI_CONTEXT_TEXT ) )

    )

    )

    );

    **********

    And so I changed it to this:

    **********

    $permalink_options = array(

    ‘mod_rewrite’ => array(

    ‘title’ => __( ‘Permalink type’ ),

    ‘type’ => ‘radio’,

    ‘options’ => array(

    ’0′ => sprintf( __( ‘<span>None</span> %s‘ ), bb_get_uri( ‘forums.php’, array( ‘id’ => 1 ), BB_URI_CONTEXT_TEXT ) ),

    ’1′ => sprintf( __( ‘<span>Numeric</span> %s‘ ), bb_get_uri( ‘/1′, null, BB_URI_CONTEXT_TEXT ) ),

    ‘slugs’ => sprintf( __( ‘<span>Name based</span> %s‘ ), bb_get_uri( ‘/first-forum’, null, BB_URI_CONTEXT_TEXT ) )

    )

    )

    );

    **********


    aaironman
    Member

    @aaironman

    Good now – all you have to do is turn off permalinks after you move a directory.

    If you want the Permalinks options to work, you have to change the “options-permalinks.php” file. Mine initially looked like this:

    **********

    $permalink_options = array(

    ‘mod_rewrite’ => array(

    ‘title’ => __( ‘Permalink type’ ),

    ‘type’ => ‘radio’,

    ‘options’ => array(

    ’0′ => sprintf( __( ‘<span>None</span> %s‘ ), bb_get_uri( ‘forums.php’, array( ‘id’ => 1 ), BB_URI_CONTEXT_TEXT ) ),

    ’1′ => sprintf( __( ‘<span>Numeric</span> %s‘ ), bb_get_uri( ‘forums/1′, null, BB_URI_CONTEXT_TEXT ) ),

    ‘slugs’ => sprintf( __( ‘<span>Name based</span> %s‘ ), bb_get_uri( ‘/forums/first-forum’, null, BB_URI_CONTEXT_TEXT ) )

    )

    )

    );

    **********

    And so I changed it to this:

    **********

    $permalink_options = array(

    ‘mod_rewrite’ => array(

    ‘title’ => __( ‘Permalink type’ ),

    ‘type’ => ‘radio’,

    ‘options’ => array(

    ’0′ => sprintf( __( ‘<span>None</span> %s‘ ), bb_get_uri( ‘forums.php’, array( ‘id’ => 1 ), BB_URI_CONTEXT_TEXT ) ),

    ’1′ => sprintf( __( ‘<span>Numeric</span> %s‘ ), bb_get_uri( ‘/1′, null, BB_URI_CONTEXT_TEXT ) ),

    ‘slugs’ => sprintf( __( ‘<span>Name based</span> %s‘ ), bb_get_uri( ‘/first-forum’, null, BB_URI_CONTEXT_TEXT ) )

    )

    )

    );

    **********


    Ben L.
    Member

    @nightgunner5

    I don’t understand what you did. When you change the folder name, the pretty permalinks gets confused. All you have to do is go into permalinks settings and save without making any changes. This works the same way in WordPress.


    Ben L.
    Member

    @nightgunner5

    I don’t understand what you did. When you change the folder name, the pretty permalinks gets confused. All you have to do is go into permalinks settings and save without making any changes. This works the same way in WordPress.


    aaironman
    Member

    @aaironman

    All I know is that it wouldn’t work before and now it works perfectly.


    aaironman
    Member

    @aaironman

    All I know is that it wouldn’t work before and now it works perfectly.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.