Skip to:
Content
Pages
Categories
Search
Top
Bottom

can not select db error


  • techhost
    Member

    @techhost

    Help ….

    I have logged onto my database locally . ..and its fine .. . I have the exact database name, user, and password in the config file. I have tried ‘localhost’ and the actual server name/path

    and I still can not get the the installation started. I can not get past “cannot select db”

    What is the mistery and i thought this was an easy setup?

    Please help with this install .. .. .

Viewing 12 replies - 1 through 12 (of 12 total)

  • JanEllers
    Member

    @janellers

    Do the user have enough rights?


    chrishajer
    Participant

    @chrishajer

    It is an easy setup. There is something wrong with your configuration. It’s difficult for anyone here to diagnose since we won’t be able to see your actual database connection details to help.


    techhost
    Member

    @techhost

    here are my settings for the config.php Sorry for not posting it at first.

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘sameasUSER’);

    define(‘BBDB_USER’, ‘sameasDB’);

    define(‘BBDB_PASSWORD’, ‘xxxxxxxxx’);

    define(‘BBDB_HOST’, ‘localhost’);

    define(‘BBDB_CHARSET’, ‘utf8′);

    define(‘BBDB_COLLATE’, ”);

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://www.rocklineproduction.com/rockline_forum/bbpress/’;

    // What are you going to call me?

    $bb->name = ‘Rockline Production Forum’;

    // This must be set before you run the install script.

    $bb->admin_email = ‘myemail@hosttechs.net’;

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = true;

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = 8;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ”; // Example: ’0123456789ab’

    // I didn’t change anything below that which is above .. . .. .


    chrishajer
    Participant

    @chrishajer

    What I was saying before is that no one will be able to help you without access to your server. Since you obfuscated the connection details to post them here, no one can look at them and see what’s wrong with them. Someone needs to be able to log into your control panel or host, see the database details there, then ensure that those same exact details are entered in your config.php. You don’t have a syntax error in your config.php, one of the pieces of information you’ve entered there is incorrect and only you can see what that is.


    chrishajer
    Participant

    @chrishajer

    Wait, what’s this:

    Warning: version_compare() has been disabled for security reasons in d:hostingarock1rockline_forumbbpressbb-includesdb-base.php on line 479
    Cannot select DB.

    You didn’t post the first part of that message which I received when trying to access your forum.

    Do you know what version MySQL is installed? You could probably work around that. The fact that you still have a “Cannot select DB” error after the warning means there is probably still a problem with your four connection details.


    techhost
    Member

    @techhost

    chrishajer … I was relutant to post the total access info for security reason . . ..

    so heres the details . . .

    define(‘BBDB_NAME’, ‘rocklineforum’); // The name of the database

    define(‘BBDB_USER’, ‘rocklineforum’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘Arnoldie1′); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few


    techhost
    Member

    @techhost

    I believe I have 4.? mysql . . I will double check that right now . . .


    techhost
    Member

    @techhost

    chrishajer .. … the version of mysql is 4.1


    techhost
    Member

    @techhost

    I even tried to replace ‘localhost’ with the real hostname path .. . .but as u know

    that didn’t work either(should the real hostname address work..? on a good config setup) .. ..


    techhost
    Member

    @techhost

    Wait, what’s this:

    Warning: version_compare() has been disabled for security reasons in d:hostingarock1rockline_forumbbpressbb-includesdb-base.php on line 479

    Cannot select DB.

    I don’t know what this is either .. .. I got this the first time i tried the install.php . .. .. .. Then I fixed the (uri)line, because I had forgotten the ‘.com’ in the address

    $bb->uri = ‘http://www.rocklineproduction.com/rockline_forum/bbpress/’;

    then first part of the error went away and all I had was the ‘Connot selectDB’ .. . .and now

    the first part is back again .. … …


    chrishajer
    Participant

    @chrishajer

    I would not recommend posting your connection details here. Please change your database connection details with the host if you can. I guess since they’re not working anyway there’s probably not much harm. I would change the password at least.

    Here’s the problem. You can post the connection details here, but without someone having access to what the host says the connection details SHOULD be, there’s no way to verify that what you are posting here and using are correct. Only you can verify that they are identical. You can triple check the database name, username and password and verify that they’re correct, letter my letter. So, my guess is that the host is wrong. It’s trying localhost and not finding a database there by that name. So my SWAG is that you need to put a hostname there.

    MySQL 4 is required, so MySQL 4.1 should be fine. That’s an interesting warning though, I don’t think I’ve seen that before. Once your forum is installed, you should probably file a trac bug on that since I don’t think the possibility of that function being disabled has been covered.


    chrishajer
    Participant

    @chrishajer

    You can also contact me using any of the contact information on the website linked in my profile if you would like help resolving this off list. You will need to be willing to share the control panel log in and access to your config.php.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.