Skip to:
Content
Pages
Categories
Search
Top
Bottom

Bug? BBPress 2.2/Multisite/BP user roles


  • Prometheus Fire
    Participant

    @prometheus-fire

    I’ve been following the updates to user roles in BBpress, but I think I’ve got a problem that may actually be a bug.

    My setup is WP 3.5 multisite with BuddyPress. I have BBpress activated only on the main site. It’s not available to the subsites at all.

    It seems however, that network members are being added to the subsites with the user role of participants. It doesn’t happen on all the sites, but I haven’t been able to narrow it down to what and why.

    Generally speaking, the users don’t need to be added to the subsites since they are all just blogs anyhow and buddypress handles all the networking stuff associated with that. The issue is that the user’s My Sites menu in the WordPress admin bar for all those user seems to continually proliferate with with websites as they get added to them. It doesn’t seem to be a situation where the user visits the site and gets added as a participant (note, they are not added as a subscriber). The issues does not effect the Sites tab of the user’s BP profile. It is only the menu bar.

    I keep getting messages from users saying that they aren’t users of the other members blogs but they keep showing up in the list. If this is intended, it creates a rather awkward user experience, and how do I turn it off? If its not intended, say so and I’ll create a trac ticket.

Viewing 2 replies - 1 through 2 (of 2 total)

  • amandafrench
    Participant

    @amandafrench

    I have this problem too, with a similar setup — both multisite and BuddyPress.


    Ormtung
    Participant

    @ormtung

    I’ve the same problem.

    User Role: Super Admin
    Setup: Multisite
    WPVersion: 3.5
    BBPVersion: 2.2.3

    When activating bbpress form my own site I’m not propagated as a subscriber to the other sites.
    When I activate bbpress for the main site, the admin site, I become member of that site but no other sites. BUT when I as the network admin list out all the sites I become members of all the sites. So I’m guessing it is a bug.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.