Skip to:
Content
Pages
Categories
Search
Top
Bottom

buddypress activity – bbpress forum activity showing as posted 44 years ago!


  • acasmi
    Participant

    @acasmi

    This is an odd problem.

    Whenever anyone posts to the bbpress forums, the relevant activity notification shows up in the buddypress activity stream (frontend) as “44 Years, 1 month ago” and in the back end activity stream as “January 1, 1970 at 1:00 am” regardless of when it is posted (although obviously not 44 years ago!)

    All the other activity posts (friend requests etc) show the correct times.

    I have the timezone in WordPress dashboard set to UTC+1 (I am in Europe). WordPress, buddypress and bbpress are all current and up to date. We have the site running on a Windows IIS server.

    Anyone help on this would be greatly appreciated!

    (crossposted to buddypress.org as I have no idea if bbpress or buddypress is the problem, or neither!)

Viewing 2 replies - 1 through 2 (of 2 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Odd. Could be a bug in several different places, but bbPress does use BuddyPress’s bp_core_current_time() function before calling bp_activity_add() in BBP_BuddyPress_Activity::record_activity().

    I’d start your trouble shooting there, and see what time is being calculated.

    I’ve seen this issue before but I can’t remember what it is :(

    I searched here on bbPress but nothing, a Google search does show lots of bbPress v1.x forum sites with this error bug.

    Do you have any other plugins or custom functions that are adjusting/using server time?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.