Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blank Screen

Viewing 20 replies - 1 through 20 (of 20 total)

  • hanjra
    Member

    @hanjra

    I have read all related scripts on the forum, but i cant login. I installed whole bbpress twice but still now success.


    chrishajer
    Participant

    @chrishajer

    If you’re getting a blank screen, it’s likely a 500 Internal Server Errror. If you have access to logs, you will see what caused it.

    Alternatively, you probably have an error in a file you edited. This error does not exist in the default installation. I would look carefully at any file you edited for syntax errors.

    Also, whatever you’re doing you’ve done twice since it happened both times. Look for the common file that you might have edited.

    If that does not work, contact me off-site at information linked to my profile.


    hanjra
    Member

    @hanjra

    the site is still showing blank screen as i press login… otherthings are normal… I cant login…cleared cache, cookies blah blah still nothing. please anyone help me.


    hanjra
    Member

    @hanjra

    can anybody help me out?? i just installed the fresh version and even then having same problem … what may be the cause?? it is my site causing problem http://www.pimpsymbian.com


    hanjra
    Member

    @hanjra

    I am having no log errors


    hanjra
    Member

    @hanjra

    These are the errors i am getting

    [21-Aug-2008 06:00:35] PHP Warning: Cannot modify header information – headers already sent by (output started at /var/www/vhosts/pimpsymbian.com/httpdocs/pimpforum/bb-config.php:1) in /var/www/vhosts/pimpsymbian.com/httpdocs/pimpforum/bb-includes/pluggable.php on line 188

    [21-Aug-2008 06:00:35] PHP Warning: Cannot modify header information – headers already sent by (output started at /var/www/vhosts/pimpsymbian.com/httpdocs/pimpforum/bb-config.php:1) in /var/www/vhosts/pimpsymbian.com/httpdocs/pimpforum/bb-includes/pluggable.php on line 228


    chrishajer
    Participant

    @chrishajer

    Sounds like you have a syntax error in the secret keys or cookie path that is creating trouble for bbPress creating the cookies. Line 188 of pluggable.php (in the 0.9.0.2 release, anyway) looks like this:

    setcookie($bb->authcookie, $cookie, $expire, $bb->cookiepath, $bb->cookiedomain);

    Can you post your bb-config.php with as little editing as possible? There’s probably something wrong in that file.

    Alternatively, check bb-config.php with the php command:

    [~pimpforum ] php -l bb-config.php
    No syntax errors detected in bb-config.php

    That’s an L, like php -L, but lowercase, in the command.


    hanjra
    Member

    @hanjra

    code

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘*******’); // The name of the database

    define(‘BBDB_USER’, ‘*****’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘******’); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old bb-config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change BB_SECRET_KEY to a unique phrase. You won’t have to remember it later,

    // so make it long and complicated. You can visit https://www.grc.com/passwords.htm

    // to get a phrase generated for you, or just make something up.

    // If you are integrating logins with WordPress, you will need to match the value

    // of the “SECRET_KEY” in the WordPress file wp-config.php

    define(‘BB_SECRET_KEY’, ‘*************************************’); // Change this to a unique phrase.

    // If you are running multiple bbPress installations in a single database,

    // you will probably want to change this.

    $bb_table_prefix = ‘bb_’; // Only letters, numbers and underscores please!

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BB_LANG to ‘de’

    // to enable German language support.

    define(‘BB_LANG’, ”);

    /* Stop editing */

    if ( !defined(‘BB_PATH’) )

    define(‘BB_PATH’, dirname(__FILE__) . ‘/’ );

    require_once( BB_PATH . ‘bb-settings.php’ );

    ?>

    That is my bb-config.php


    hanjra
    Member

    @hanjra

    and how to use the above mentioned php command??


    chrishajer
    Participant

    @chrishajer

    The problem with editing your bb-config.php and posting it here is that you likely edited out anything in a password or secret key that is causing you a problem. So posting the edited version is mostly useless.

    You use the php -l bb-config.php from a Linux command line. The edited version you posted here checks out fine, but I suspect your live, unedited version does not.


    chrishajer
    Participant

    @chrishajer

    If you used the WordPress secret key generator API to create the keys for WordPress and are using those keys for bbPress, it’s entirely possible the key works fine in WordPress but not bbPress.

    http://bbpress.org/forums/topic/10-alpha-wp-integration-messed-logins#post-18286


    hanjra
    Member

    @hanjra

    Thanks for this.. yes that is right i was using that wordpress key… now tell me ,, will i have to change the key of my wordpress too or only i need to change the key of bbpress. Or i ll have to remove all the bbpress tables and then install again or just change the key only.

    ps: if i want to integrate the bbpress with wordpress then what will i have to do.. to change the key of wordpress too??


    hanjra
    Member

    @hanjra

    Ok i tell you what i did… i replaced the BB_Secret_key with only alphabetic and numeric but even then i couldnt login.

    Then i changed the keys of wordpress too with alphabetic and numberic only but then i couldnt login to wordpress too. I was having same login problem and same error message as i am having with bbpress.

    So then i replaced the wp-config file with old one and then i was able to login. Problem still exists with bbpress.

    Please read my above post too and tell me what to do thanks a lot for this help.


    chrishajer
    Participant

    @chrishajer

    Have you tried clearing your cookies? Since you changed the keys for WordPress and bbPress, the cookies will be different and your old ones might be fouling things up.

    You can also contact me off list and I might be able to help you.


    hanjra
    Member

    @hanjra

    I did cleare the cookies and cache but was not able to signin even in wordpress.

    I ll try by restarting the pc after clearing all cookies and cache. In fact i use 2 to 3 browsers at a time. IE , Opera, and safari.


    hanjra
    Member

    @hanjra

    whenever i try to login with correct password, i face this blank screen and if i use wrong password, i am directed to the login page with incorrect password.

    Please folks help me


    fel64
    Member

    @fel64

    Have you tried resetting your password? Is a new user able to log in?


    hanjra
    Member

    @hanjra

    Yes i tried resetting the password…. one more thing… even i replaced the key with only numerics and alphabets but even then when i got resetted password, it contained special characters…

    I think these special characters making problem.


    chrishajer
    Participant

    @chrishajer

    The password normally contains special characters and that’s fine. That’s how I can usually tell if the bbPress is an old version or new version, based on the password being sent out when you register.

    There is no problem with having special characters in the secret keys: it’s just that if they’re not properly escaped, the server will choke on the config file because the bb-config.php does not have proper syntax.

    So, make sure the keys are the same for WordPress and bbPress, make sure the bb-config.php is syntactically correct (php -l bb-config.php from a Linux command line) and then figure out why you can’t log in.

    You can also make the secret keys really short and easy to compare while testing to see if that’s the problem.

    It’s also worthwhile to check any php file you edited for the proper syntax. Maybe once you log in, you are being served another page that has a syntax error (a template file?) and that is causing the blank screen.

    Also, access to error logs will help with this, if you have them.


    gimecoffee
    Member

    @gimecoffee

    I just finished tracking down a similar problem (Blank screen on new install) for a colleague. I think chrishajer may be on to your problem with the key but not all linux installs allow php command lines and my httpd access and error logs gave no useful info.

    My colleague had copied the WP secret BUT not the whole thing. He stopped on an escape string (”) which made php think the last single quote in the definition syntax was part of the key. This made the entire rest of the file part of the text in the definition instead of letting the php interpreter at it. For example:

    define(‘BB_SECRET_KEY’, ‘Ts[5wi;{?2Sp%”‘);

    should have been

    define(‘BB_SECRET_KEY’, ‘Ts[5wi;{?2Sp%”‘} 4N_zAd6′);

    You can see in the first example that the escape character “” is what breaks the rest of the file for php. If your WP key is ending with “” (right before the single quote) then I would try deleting that character in both places and see if that does the trick.

    Happy hunting

    Rois

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.