Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbpress won’t install


  • chanzero
    Member

    @chanzero

    Hi all,

    I’ve got some weirdness going on with my attempts to install bbpress. I have successfully installed it a number of times in various directories but always removed it (by deleting all bb_ tables in the database, and deleting the directory as well) because various features I wanted/needed at the time weren’t available.

    However I just installed it for a client and that went well so I figured I’d give it another shot on my site. Unfortunately whenever I try to install it, things go fine until I get the “Finished! Now you can log in” message — then I get the message “Doesn’t look like you’ve installed bbPress yet, go here.”

    And I’m stuck in this inescapable loop. I’ve tried uninstalling and reinstalling several times all with the same effect. Hopefully someone here has an idea what’s wrong

    BTW I’ve got bbpress & WP on the same database and have my config variables filled in for integrating

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer
    Participant

    @chrishajer

    Do you have an example of where this is happening?

    Maybe there is something with a previous integrated installation that is fouling things up? A WP plugin maybe? Some data in a wp_ table that bbPress is trying to read?


    chanzero
    Member

    @chanzero

    http://www.popcultureshock.com/pcs/forum/

    I thought of what you said and I’ve looked and found nothing. I looked in wp_options and saw bbsync which I deactivated & deleted.


    fel64
    Member

    @fel64

    Sounds like your bb_forums table is empty. If it is, bb thinks it hasn’t been installed yet. Just continue with this install from here: http://www.popcultureshock.com/pcs/forum/bb-admin/install.php?step=1


    chanzero
    Member

    @chanzero

    fel64: you’re right, bb_forums is indeed empty. however i’ve run through the entire installation numerous times, including the page you linked to, and nothing ever populates there. which is strange. should i put some dummy data in there to trick the install?


    fel64
    Member

    @fel64

    Yeah, give it a shot.


    chrishajer
    Participant

    @chrishajer

    Can you add this line to your config.php right after the 4 MySQL setting lines:

    $bb->debug = 1;

    That should provide some useful information. Not sure if it will help here though.


    chanzero
    Member

    @chanzero

    Ok, I added data in the bb_forums table and now the forums come up. Yay! My problem now is that I can’t get into the forum admin section. When I installed bbpress, it found user “chanzero” and assigned my account as keymaster but when I log in it won’t show me the admin link, nor can i surf to /bb-admin/

    I looked at my RoleID in wp_users and it’s 4, which I think should grant me access to BB admin?


    chanzero
    Member

    @chanzero

    Ok, I fixed my lack of admin access by going into wp_usermeta and deleting the “bb_capabilities” key for my wp user ID, then re-installing. All seems healthy now! Thanks everyone

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.