Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress redirects away from itself if no frontslash after URL!


  • DougJoseph
    Member

    @dougjoseph

    Hello!

    I just downloaded and installed the latest version of bbPress — version 1.0.2.

    In the database ( bb_option | uri ), we see the full URL to the forum:

    http://domain.com/folder/

    Now, if I type that address into a browser, the forum loads fine.

    However, if I type it this way (without the trailing frontslash)…

    http://domain.com/folder

    … I get redirected to this:

    http://domain.com/domain.com/folder/

    Which leads to nowhere!

    To see this in action, paste or type these two URIs into your browser:

    http://authorstock.com/forum/

    http://authorstock.com/forum

    …With the only difference being the trailing frontslash.

    Argh! Can anyone help me know how to fix this?

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • What’s in your .htaccess?

    I can’t repro that and if I use forum or forum/ it works fine for me…


    DougJoseph
    Member

    @dougjoseph

    I should have mentioned I am on an IIS 7 server, so there is no .htaccess file, and I removed all “rewrite” rules from my web.config.

    Thank you for clicking, and for reporting that the site is working fine for you.

    That must mean my problem is local only to my PC. How could that be?

    It is definitely still showing the same problem. Just tried again even as I was typing this.

    ???

    Would anyone else be kind enough to click and report if you can repro the problem? Thanks.


    chrishajer
    Participant

    @chrishajer

    It’s broken for me, using Firefox 3.5.6 on Windows XP. clicking without the slash gets me http://authorstock.com/authorstock.com/forum/


    DougJoseph
    Member

    @dougjoseph

    Thanks.

    Well, at least I’m not crazy. :-)

    OK, I am using IE on a Win XP SP3 system. Problem is reproducible.

    Now, I am using Firefox 3.0.16 on a Win XP SP3 system. Problem is reproducible.

    @ipstenu

    What OS are you using? And what browser?

    Thanks for your help.


    DougJoseph
    Member

    @dougjoseph

    I just tried again using Apple Safari 4.0.4 on a Win XP SP3 system. Problem is reproducible.

    In all three browsers the OS stayed the same.

    @chrishajer: Your test was also on Win XP. Common element?


    chrishajer
    Participant

    @chrishajer

    Checked from command line on Linux and it redirects if you don’t use the slash:

    [~]$ curl -I http://authorstock.com/forum
    HTTP/1.1 301 Moved Permanently
    Content-Length: 168
    Content-Type: text/html; charset=UTF-8
    Location: http://authorstock.com/authorstock.com/forum/
    Server: Microsoft-IIS/7.0
    X-Powered-By: ASP.NET
    Date: Tue, 29 Dec 2009 23:36:34 GMT

    [~]$ curl -I http://authorstock.com/forum/
    HTTP/1.1 200 OK
    Content-Length: 0
    Content-Type: text/html; charset=UTF-8
    Server: Microsoft-IIS/7.0
    X-Pingback: http://authorstock.com/forum/xmlrpc.php
    X-Powered-By: ASP.NET
    Date: Tue, 29 Dec 2009 23:36:40 GMT

    Can you access any other directories and get the index file instead of a redirect? Is there a way to ensure that index.php is the index file for the directory?

    1. In the IIS Manager, double-click Default Document.

    2. Click Add, then enter index.php and click OK.


    chrishajer
    Participant

    @chrishajer

    For example, try this directory with and without the slash:

    http://authorstock.com/media

    http://authorstock.com/media/

    Same sort of redirect happens. Looks like it’s a configuration issue with the server.


    DougJoseph
    Member

    @dougjoseph

    You are right! It happens with any other directory on my site!

    So maybe this is a hosting set-up issue. At this point it seems it has nothing to do with bbPress.

    I so appreciate that you folks were willing to take a few minutes to help! Because of you I am closer to sorting this out.

    I will lurk around inside my hosting settings on GoDaddy.com and see if I can figure out what’s up.


    DougJoseph
    Member

    @dougjoseph

    I found that the problem affected all my domains hosted on that account, and every subfolder in all those domains.

    I called GoDaddy.com and they were unable to fix it. The best I can figure is that somehow I caused it with a mix of adding and removing virtual directories.

    I ended up having them cancel that whole hosting account and creating a new one, and then I restored all my domains from the backups.

    As soon as the DNS info repopulates out through the net, I will be able to test to see if wiping clean and starting over… fixed the problem.


    DougJoseph
    Member

    @dougjoseph

    Success. Wiping out the whole hosting account and restoring it from backups has fixed the problem.


    chrishajer
    Participant

    @chrishajer

    That would be “the nuclear option” I think!

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.