Skip to:
Content
Pages
Categories
Search
Top
Bottom

BBPress on XAMPP – ‘page isn’t redirecting properly’

  • 0. XAMPPlite installation on a USB thumbdrive

    with ‘WordPress’, ‘Mediawiki’, ‘Vanilla’, Gallery2′ running smoothly

    1. BBPress install complete

    2. See forum page, login

    3. Write a post, click ‘send post’

    4. Get a ‘page isn’t redirecting properly …. maybe cookie warning’

    5. On Forum main page the post is visible, a click brings above warning

    6. Check again config. php $bb-> path = ‘/’; and ‘settings. php’; can’t find the wrong reference ‘X:/htdocs/bbpress/’ I entered in 1st install page (and changed in config. php to ‘/’.

    7. Can someone point out the file to change?

    Thanks for your help

    Detailed log of events below

    0. XAMPPlite installation on a USB thumbdrive

    with ‘WordPress’, ‘Mediawiki’, ‘Vanilla’, Gallery2′ running smoothly

    1. Extracted bbpress into htdocs directory

    2. Changed bbpress config.php (see below)

    3. Started install and went throught step 1 (see below), step 2 (got password) and

    4. Came to the site ‘knowledgeflowsaround.us/forum (typing: ‘http://localhost/bbpress/’)

    (strangely ugly, so apparently theme did not load, somewhere I set a wrong path?)

    5. Tried to login: Access forbidden!

    =>You don’t have permission to access the requested object.

    It is either read-protected or not readable by the server.

    6. Clicked on any other link on the forum page and got the same result

    7. Checked config file of ‘Vanilla’ (‘settings.php’) there the same parameter worked (irrelevant as Vanilla is Vanilla and bbpress/bbpress)

    =>Note: Write protection can not be the problem as it is XAMPPlite on a PC so nothing is protected

    8. Changed config.php $bb->path =’/’; and now I can see my forum

    9. Login, okay

    10. Go to ‘Topic – ADD NEW’ and write a new topic, click ‘Send Post’ and get

    11. ‘The page isn’t redirecting properly’ This problem can sometimes be caused by disabling or refusing to accept cookies’

    12. Start the never used IE and with ‘localhost/bbpress’ go to the forum. click on any link and get (after long wait) nothing

    13. In Firefox try other links it all goes to the same ‘the page isn’t redirecting properly (cookies are enabled)

    => So I think in 1step install the ‘Location: X:htdocsbbpress’ has to be changed but in what file?

    14. Check ‘settings.php and register.php’ but the wrong string ‘X:/htdocs/bbpress/’ from below is not found.

    15. Do you have an answer?

    bbpress config file

    // define(‘BBDB_NAME’, ‘bbpress’);

    // define(‘BBDB_USER’, ‘root’);

    // define(‘BBDB_PASSWORD’, ‘password’);

    // define(‘BBDB_HOST’, ‘localhost’);

    // $bb->domain = ‘http://localhost/bbpress’;

    // $bb->path = ‘X:/htdocs/bbpress/’; (=> changed to ‘/’; and could access forum, add a post, but can’t see)

    // $bb->name = ‘knowledgeflowsaround.us/forum’;

    1step install

    login name: admin

    website: http://localhost/bbpress/

    location: X:htdocsbbpress/

    1st Forum: Working in DevAid

Viewing 4 replies - 1 through 4 (of 4 total)

  • teknoseyir
    Member

    @teknoseyir

    Hi,

    Try changing values like that:

    $bb->domain = ‘http://localhost’;

    $bb->path = ‘/bbpress/’;


    kfordham281
    Member

    @kfordham281

    Thanks teknoseyir! I was having this same issue and your solution worked great.

    MAN….. see what searchin does? Fixed my problem too! Thx!

    Lool, I had the exact same problem, and you’re right: searching IS helpful!

    Hahaha, it’s amazing how I fixed 4 or 5 issues in 4 or 5 minutes thx to searching this forum! I must say that it’s very well referenced and documented. Great job guys!

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.